aboutsummaryrefslogtreecommitdiffstats
path: root/community/openzwave/0001-fix-build-on-ppc64le.patch
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2018-12-19 10:24:42 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-12-19 10:27:50 +0000
commit2f5b01f68fbe7231f74c688b83e535ee2335c79f (patch)
treed6c60c3bdde6a5fdc0df0c350e2b4f132ea5f495 /community/openzwave/0001-fix-build-on-ppc64le.patch
parent4582057441441eede97a46b6638f254ee38b1949 (diff)
downloadaports-2f5b01f68fbe7231f74c688b83e535ee2335c79f.tar.bz2
aports-2f5b01f68fbe7231f74c688b83e535ee2335c79f.tar.xz
community/openzwave: build fix for ppc64le
Update license, modernize APKBUILD
Diffstat (limited to 'community/openzwave/0001-fix-build-on-ppc64le.patch')
-rw-r--r--community/openzwave/0001-fix-build-on-ppc64le.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/openzwave/0001-fix-build-on-ppc64le.patch b/community/openzwave/0001-fix-build-on-ppc64le.patch
new file mode 100644
index 0000000000..93abcf7313
--- /dev/null
+++ b/community/openzwave/0001-fix-build-on-ppc64le.patch
@@ -0,0 +1,28 @@
+From 5fc166b05611bd5cf7db83284181416e1c08a350 Mon Sep 17 00:00:00 2001
+From: Leonardo Arena <rnalrd@alpinelinux.org>
+Date: Wed, 19 Dec 2018 10:11:38 +0000
+Subject: [PATCH] fix build on ppc64le
+
+/home/buildozer/aports/community/openzwave/src/openzwave-1.4.164/cpp/src/command_classes/DoorLockLogging.cpp:312:15: error: passing argument 1 to restrict-qualified parameter aliases with argument 4 [-Werror=restrict]
+
+Use default Alpine optimization flag
+---
+ cpp/build/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cpp/build/Makefile b/cpp/build/Makefile
+index a632f79..2d7c337 100644
+--- a/cpp/build/Makefile
++++ b/cpp/build/Makefile
+@@ -15,7 +15,7 @@
+ # what flags we will use for compiling in debug mode
+ DEBUG_CFLAGS := -Wall -Wno-unknown-pragmas -Wno-inline -Wno-format -Werror -Wno-error=sequence-point -Wno-sequence-point -ggdb -DDEBUG -fPIC -DSYSCONFDIR="\"$(PREFIX)/etc/openzwave/\""
+ # what flags we will use for compiling in release mode
+-RELEASE_CFLAGS := -Wall -Wno-unknown-pragmas -Werror -Wno-format -Wno-error=sequence-point -Wno-sequence-point -O3 -DNDEBUG -fPIC -DSYSCONFDIR="\"$(PREFIX)/etc/openzwave/\""
++RELEASE_CFLAGS := -Wall -Wno-unknown-pragmas -Werror -Wno-format -Wno-error=sequence-point -Wno-error=restrict -Wno-sequence-point -Os -DNDEBUG -fPIC -DSYSCONFDIR="\"$(PREFIX)/etc/openzwave/\""
+ #what flags we will use for linking in debug mode
+ DEBUG_LDFLAGS := -g
+
+--
+2.19.2
+