aboutsummaryrefslogtreecommitdiffstats
path: root/community/optipng
diff options
context:
space:
mode:
authorMichael Koloberdin <koloberdin@gmail.com>2016-09-09 16:22:30 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-10-19 15:11:27 +0000
commit3e36a3faaf8421c706ec21271060faaa8db4c38e (patch)
treee99d35f9be80cd8126b0fbe6da85ffa3cad697c2 /community/optipng
parent09a192e858d693d39ee48eac12ce51c4299b1025 (diff)
downloadaports-3e36a3faaf8421c706ec21271060faaa8db4c38e.tar.bz2
aports-3e36a3faaf8421c706ec21271060faaa8db4c38e.tar.xz
community/optipng: Move from testing
Diffstat (limited to 'community/optipng')
-rw-r--r--community/optipng/APKBUILD35
-rw-r--r--community/optipng/builtin-zlib.patch14
2 files changed, 49 insertions, 0 deletions
diff --git a/community/optipng/APKBUILD b/community/optipng/APKBUILD
new file mode 100644
index 0000000000..2ae7ed85b3
--- /dev/null
+++ b/community/optipng/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Michael Koloberdin <koloberdin@gmail.com>
+pkgname=optipng
+pkgver=0.7.6
+pkgrel=1
+pkgdesc="Compresses PNG files to a smaller size, without losing any information."
+url="http://optipng.sourceforge.net/"
+arch="all"
+license="ZLIB"
+depends=""
+makedepends="libpng-dev "
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ -with-system-libs || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make prefix="$pkgdir/usr" mandir="$pkgdir/usr/share/man" install || return 1
+
+ # install license
+ install -Dm0644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE" || return 1
+}
+
+md5sums="568e0738358450eca69ecf578d48f26c optipng-0.7.6.tar.gz"
+sha256sums="4870631fcbd3825605f00a168b8debf44ea1cda8ef98a73e5411eee97199be80 optipng-0.7.6.tar.gz"
+sha512sums="d31d7494c23413d87b601a706cc2faf82923156a818da66e0bfad11741aed065db8f1b0c088d2abd66899ac192408c05f594295ded2684c4549c5f03b140a184 optipng-0.7.6.tar.gz"
diff --git a/community/optipng/builtin-zlib.patch b/community/optipng/builtin-zlib.patch
new file mode 100644
index 0000000000..a09cdad1d4
--- /dev/null
+++ b/community/optipng/builtin-zlib.patch
@@ -0,0 +1,14 @@
+diff -urp optipng-0.7.6-orig/configure optipng-0.7.6/configure
+--- optipng-0.7.6-orig/configure 2014-12-01 07:25:00.000000000 +0200
++++ optipng-0.7.6/configure 2016-05-17 20:56:08.950224977 +0300
+@@ -234,6 +234,10 @@ then
+ fi
+ if test "$CPPFLAGS"
+ then
++ if test "$with_system_zlib" -eq 0
++ then
++ CPPFLAGS="-I../zlib ${CPPFLAGS}"
++ fi
+ sed_preconfig_libpng="
+ $sed_preconfig_libpng
+ s|^CPPFLAGS *=.*|CPPFLAGS = $CPPFLAGS|