aboutsummaryrefslogtreecommitdiffstats
path: root/community/oscam
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-10-07 17:55:44 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-10-10 12:04:42 +0000
commit57b589e7f643164be2eb210a9f732e64256e2bae (patch)
treef3a087f148b70a89867936b9aba583d24a226576 /community/oscam
parent319634d1fba4ec3e0571a44894587b90727f4124 (diff)
downloadaports-57b589e7f643164be2eb210a9f732e64256e2bae.tar.bz2
aports-57b589e7f643164be2eb210a9f732e64256e2bae.tar.xz
community/oscam: rebuild against libressl
Diffstat (limited to 'community/oscam')
-rw-r--r--community/oscam/APKBUILD41
-rw-r--r--community/oscam/libressl.patch13
2 files changed, 36 insertions, 18 deletions
diff --git a/community/oscam/APKBUILD b/community/oscam/APKBUILD
index cadcd0fd52..2b01d97ac4 100644
--- a/community/oscam/APKBUILD
+++ b/community/oscam/APKBUILD
@@ -3,14 +3,14 @@
pkgname=oscam
verbase=1.20
pkgver=1.20_svn20160307
-pkgrel=2
+pkgrel=3
pkgdesc="An Open Source Conditional Access Module software"
url="http://www.streamboard.tv/oscam/"
arch="all"
license="GPL"
depends=""
depends_dev=""
-makedepends="$depends_dev bash subversion paxmark linux-headers openssl-dev
+makedepends="$depends_dev bash subversion paxmark linux-headers libressl-dev
libusb-dev pcsc-lite-dev"
install="$pkgname.pre-install"
pkgusers="$pkgname"
@@ -20,13 +20,15 @@ disturl="dev.alpinelinux.org:/archive/$pkgname/"
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz
$pkgname.initd
$pkgname.confd
- $pkgname.conf"
+ $pkgname.conf
+ libressl.patch
+ "
-_builddir="$srcdir"/oscam-$pkgver
+builddir="$srcdir"/oscam-$pkgver
prepare() {
local i
- cd "$_builddir"
+ cd "$builddir"
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
@@ -35,7 +37,7 @@ prepare() {
}
build() {
- cd "$_builddir"
+ cd "$builddir"
make allyesconfig
make OSCAM_BIN=oscam \
LIST_SMARGO_BIN=list_smargo \
@@ -46,24 +48,24 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
install -d "$pkgdir"/var/log/$pkgname/cw \
"$pkgdir"/var/run/$pkgname \
"$pkgdir"/usr/share/doc/oscam/example \
"$pkgdir"/usr/share/doc/oscam/monitor \
"$pkgdir"/usr/share/man/man1 \
"$pkgdir"/usr/share/man/man5 || return 1
- install -m644 "$_builddir"/Distribution/doc/txt/* \
+ install -m644 "$builddir"/Distribution/doc/txt/* \
"$pkgdir"/usr/share/doc/oscam/ || return 1
- install -m644 "$_builddir"/Distribution/doc/example/* \
+ install -m644 "$builddir"/Distribution/doc/example/* \
"$pkgdir"/usr/share/doc/oscam/example/ || return 1
- install -m644 "$_builddir"/Distribution/monitor/* \
+ install -m644 "$builddir"/Distribution/monitor/* \
"$pkgdir"/usr/share/doc/oscam/monitor/ || return 1
- install -m644 "$_builddir"/Distribution/doc/man/*.1 \
+ install -m644 "$builddir"/Distribution/doc/man/*.1 \
"$pkgdir"/usr/share/man/man1/ || return 1
- install -m644 "$_builddir"/Distribution/doc/man/*.5 \
+ install -m644 "$builddir"/Distribution/doc/man/*.5 \
"$pkgdir"/usr/share/man/man5/ || return 1
- install -D -m755 "$_builddir/oscam" \
+ install -D -m755 "$builddir/oscam" \
"$pkgdir/usr/bin/oscam" || return 1
install -D -m644 "$srcdir"/$pkgname.conf \
"$pkgdir"/etc/$pkgname/$pkgname.conf || return 1
@@ -82,25 +84,28 @@ package() {
list_smargo() {
pkgdesc="Tool to identify your smargo card reader"
- install -m755 -D "$_builddir"/list_smargo \
+ install -m755 -D "$builddir"/list_smargo \
"$subpkgdir"/usr/bin/list_smargo || return 1
}
dbg() {
mkdir -p "$subpkgdir"/usr/bin
- mv "$_builddir"/oscam.debug \
+ mv "$builddir"/oscam.debug \
"$subpkgdir"/usr/bin || return 1
}
md5sums="53eb0c3f7cac9dfcb4bdc1807bb32261 oscam-1.20_svn20160307.tar.gz
03a0fd1355fe4e7b0943c2e64354d833 oscam.initd
3108b2f38140b5791d15cf49dae4ad35 oscam.confd
-90939047384482ba8d4428b127b53785 oscam.conf"
+90939047384482ba8d4428b127b53785 oscam.conf
+353501796902147579f28f07c9c104b7 libressl.patch"
sha256sums="5de9323774eb345c06bb15b97bb4275c9eb180d690048ab62ca4cc7d9eed0999 oscam-1.20_svn20160307.tar.gz
1a9c0cca5eb600513aa1ae0b101bb9c7be80d0dfce611c4dbceff986fb4dafa8 oscam.initd
dd66db5c280ea6c695b55aafb972c3713e297c7ff47deff9f15f40e9c080f3fd oscam.confd
-7a2e4cb5da504027b858086966eee57fcc1cc14115a7978997857e631e459b6e oscam.conf"
+7a2e4cb5da504027b858086966eee57fcc1cc14115a7978997857e631e459b6e oscam.conf
+dca7895f8fc4e248a58d738f4a2adb0356a87e2550ff4883f23c9db33775166b libressl.patch"
sha512sums="f368a3af658d4ea926fd9ec626797e6701a86894006eac3b858c65f2be9ce7f6bdc55a72b331ca7a362b85327c24fa9b0703580084bf24fd41bccfeeb70c4f21 oscam-1.20_svn20160307.tar.gz
869d51a2e8472011ecc5b9776e5cb6dbbc87a648bb025f5c0d7c26147e4c1eb91c7d4a4f780237c9996e218bda0025107a921f14a55cf014a1f39d97e4422c4b oscam.initd
73998e9b9212c4868284aa4ed7d3a53fb61c087658f6dd8615de331fe12e1a9a1ea8941ebcc880804579d161d7954ead098315130cd07fc0fb2b368475f74e96 oscam.confd
-0f3c4b9940bd27169dfe934599525558bc712d43f07959f19dce6ccfbf0e4d35d345272500fba2bff30e4ecf23f11f72b75321f8a45df908373620349d7f8808 oscam.conf"
+0f3c4b9940bd27169dfe934599525558bc712d43f07959f19dce6ccfbf0e4d35d345272500fba2bff30e4ecf23f11f72b75321f8a45df908373620349d7f8808 oscam.conf
+edadb2ae2eb163ee269a24a6a0e160f6348ab22ca0fd6f92ca07bb1b9a10130bfae09135b6b3fa2511353639e65b6bfc77a7ef92a8e60cf09b40b2ef3affdbe0 libressl.patch"
diff --git a/community/oscam/libressl.patch b/community/oscam/libressl.patch
new file mode 100644
index 0000000000..ee723050ac
--- /dev/null
+++ b/community/oscam/libressl.patch
@@ -0,0 +1,13 @@
+diff --git a/module-webif-lib.c b/module-webif-lib.c
+index bda2286..3e5dbf9 100644
+--- a/module-webif-lib.c
++++ b/module-webif-lib.c
+@@ -866,7 +866,7 @@ SSL_CTX *SSL_Webif_Init(void)
+
+ if(cfg.http_force_sslv3)
+ {
+- ctx = SSL_CTX_new(SSLv3_server_method());
++ ctx = SSL_CTX_new(TLS_server_method());
+ #ifdef SSL_CTX_clear_options
+ SSL_CTX_clear_options(ctx, SSL_OP_ALL); //we CLEAR all bug workarounds! This is for security reason
+ #else