aboutsummaryrefslogtreecommitdiffstats
path: root/community/ospd-ikeprobe
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-09-05 14:32:01 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-09-05 14:32:01 +0000
commitddf37486b89e2a96fde032c69efd22ea13a2918e (patch)
tree742055c1a31f37b2d2157f17f338268b7194d411 /community/ospd-ikeprobe
parent2885b93b6f47ed99c31b4291248e4b910a29a6e9 (diff)
downloadaports-ddf37486b89e2a96fde032c69efd22ea13a2918e.tar.bz2
aports-ddf37486b89e2a96fde032c69efd22ea13a2918e.tar.xz
community/ospd-ikeprobe: added check, modernized APKBUILD
Diffstat (limited to 'community/ospd-ikeprobe')
-rw-r--r--community/ospd-ikeprobe/APKBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/community/ospd-ikeprobe/APKBUILD b/community/ospd-ikeprobe/APKBUILD
index fd7f0fc691..5b2ba2ea7f 100644
--- a/community/ospd-ikeprobe/APKBUILD
+++ b/community/ospd-ikeprobe/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=ospd-ikeprobe
pkgver=1.0b1
-pkgrel=2
+pkgrel=3
_pkgid=2204
pkgdesc="OSP server implementation to allow OpenVAS to remotely control a ikeprobe scanner"
url="http://www.openvas.org/"
@@ -10,24 +10,22 @@ arch="noarch"
license="GPL"
depends="python3 ospd"
makedepends="cmake python3-dev"
-install=""
-subpackages=""
source="http://wald.intevation.org/frs/download.php/$_pkgid/$pkgname-$pkgver.tar.gz"
-
builddir="$srcdir"/$pkgname-$pkgver
build() {
cd "$builddir"
- python3 setup.py build || return 1
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
}
package() {
cd "$builddir"
- python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-
-
-md5sums="97bc6b0953faf1e8883ee43360bf1e38 ospd-ikeprobe-1.0b1.tar.gz"
-sha256sums="86b29210b5c5b674352b8366a83b167c492c92e145a1637d28dd9a8f6a2ecde0 ospd-ikeprobe-1.0b1.tar.gz"
sha512sums="567b2100ab42d7effe8fb47890a3c05fb7066ef97e29f2c723a3f29fd58addac220a91dda01804e997eec126905d43d59621b7318bfa02487ed789e228fe8660 ospd-ikeprobe-1.0b1.tar.gz"