aboutsummaryrefslogtreecommitdiffstats
path: root/community/ospd-nmap
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-22 07:01:11 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-22 07:01:11 +0000
commit69d0aa6d5409d3034b25b00bc830c9a677458813 (patch)
treebb84c22f4c281a4733262e448b3f376da85b6771 /community/ospd-nmap
parentb20391da3920d62a06b648db127ddcd02023a889 (diff)
downloadaports-69d0aa6d5409d3034b25b00bc830c9a677458813.tar.bz2
aports-69d0aa6d5409d3034b25b00bc830c9a677458813.tar.xz
testing/ospd-nmap: moved from testing. Now uses only python3
Diffstat (limited to 'community/ospd-nmap')
-rw-r--r--community/ospd-nmap/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/ospd-nmap/APKBUILD b/community/ospd-nmap/APKBUILD
new file mode 100644
index 0000000000..5ce86d983e
--- /dev/null
+++ b/community/ospd-nmap/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=ospd-nmap
+pkgver=1.0b1
+pkgrel=1
+_pkgid=2218
+pkgdesc="OSP server implementation to allow OpenVAS to remotel control nmap port scanner"
+url="http://www.openvas.org/"
+arch="noarch"
+license="GPL"
+depends="python3"
+makedepends="cmake python3-dev"
+install=""
+subpackages=""
+source="http://wald.intevation.org/frs/download.php/$_pkgid/$pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+
+
+md5sums="15b56da5a7282db6de7d6e534ec064e2 ospd-nmap-1.0b1.tar.gz"
+sha256sums="b3fc890fd13f459a5892cd465811289be61374b988ac6b983b05918f5a94d0ae ospd-nmap-1.0b1.tar.gz"
+sha512sums="f251d0951ba6225844274d26187aa7b90a654ed765471f356fa7979b623c5c04c7f7527dffb9e8f28e278c3e4079a7881947787435779c57d5346520934a9d21 ospd-nmap-1.0b1.tar.gz"