aboutsummaryrefslogtreecommitdiffstats
path: root/community/paper-gtk-theme
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2017-09-27 10:35:47 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2017-09-27 10:35:47 +0200
commit5b238c4ee99a3f5cb9f8a9439fbf775d031fea81 (patch)
treeaf2e1fa8f677574aaf69f31bd44c6e932345f78e /community/paper-gtk-theme
parentfdf03781cf2f823995df60a38be6c6252fcba8b1 (diff)
downloadaports-5b238c4ee99a3f5cb9f8a9439fbf775d031fea81.tar.bz2
aports-5b238c4ee99a3f5cb9f8a9439fbf775d031fea81.tar.xz
testing/paper-gtk-theme: move to community
Diffstat (limited to 'community/paper-gtk-theme')
-rw-r--r--community/paper-gtk-theme/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/community/paper-gtk-theme/APKBUILD b/community/paper-gtk-theme/APKBUILD
new file mode 100644
index 0000000000..a895dcbf4c
--- /dev/null
+++ b/community/paper-gtk-theme/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
+pkgname=paper-gtk-theme
+pkgver=2.1.0
+pkgrel=0
+pkgdesc="Paper Theme Suite"
+url="http://snwh.org/paper"
+arch="noarch"
+options="!strip"
+license="GPL-3.0"
+depends="gtk-murrine-engine"
+makedepends="automake autoconf libtool"
+install=""
+subpackages=""
+source="paper-gtk-theme-$pkgver.tar.gz::https://github.com/snwh/paper-gtk-theme/archive/v$pkgver.tar.gz"
+builddir="$srcdir/paper-gtk-theme-$pkgver"
+
+build() {
+ cd "$builddir"
+ autoreconf -vif
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="f72806e22cdcbf14f15cfa8b20268ced paper-gtk-theme-2.1.0.tar.gz"
+sha256sums="e097f92552bfaaea1e01b431f2af1a109a7643331b9029ba207a82e3eccda197 paper-gtk-theme-2.1.0.tar.gz"
+sha512sums="2ceffba42a03d897694d1a1f4817736f6750d393174582f4dc3d19ab5563988d521558d9d7c49a3075386999562907a3ae9eea2734a0f9f423e438c89756c65c paper-gtk-theme-2.1.0.tar.gz"