aboutsummaryrefslogtreecommitdiffstats
path: root/community/paper-icon-theme
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-12-30 14:54:12 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-07 10:13:47 +0100
commit78d37d9942be8548da47259a8b0f5ea584ed1f16 (patch)
treec071a4c1c2581c76002b213923520dff8a2f90d1 /community/paper-icon-theme
parent92116a4678aa9557f35ec994424bb86ce1e21626 (diff)
downloadaports-78d37d9942be8548da47259a8b0f5ea584ed1f16.tar.bz2
aports-78d37d9942be8548da47259a8b0f5ea584ed1f16.tar.xz
tree-wide: use --buildtype=debugoptimized for meson packages
As of now we're using the buildttype 'release', which produces optimized builds but without any usable debugging info, which makes debugging crashes impossible, even if a -dbg subpackage exists. As such we should build in the buildmode 'debugoptimized' to offer proper debug symbols.
Diffstat (limited to 'community/paper-icon-theme')
-rw-r--r--community/paper-icon-theme/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/community/paper-icon-theme/APKBUILD b/community/paper-icon-theme/APKBUILD
index 279ee6a652..b5f37c11a7 100644
--- a/community/paper-icon-theme/APKBUILD
+++ b/community/paper-icon-theme/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=paper-icon-theme
pkgver=1.5.0
-pkgrel=0
+pkgrel=1
pkgdesc="Paper is a modern freedesktop icon theme"
url="https://snwh.org/paper"
arch="noarch"
@@ -18,7 +18,7 @@ builddir="$srcdir/paper-icon-theme-v.$pkgver"
build() {
cd "$builddir"
meson \
- --buildtype=release \
+ --buildtype=debugoptimized \
--prefix=/usr \
. build
ninja -C "$builddir"/build