aboutsummaryrefslogtreecommitdiffstats
path: root/community/paper-icon-theme
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2017-09-27 10:36:07 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2017-09-27 10:36:07 +0200
commited7bfce2007122394886c658e0db30a6ba91d751 (patch)
tree71a37700d4f3a483a073ab6cb79c615a0432d749 /community/paper-icon-theme
parent5b238c4ee99a3f5cb9f8a9439fbf775d031fea81 (diff)
downloadaports-ed7bfce2007122394886c658e0db30a6ba91d751.tar.bz2
aports-ed7bfce2007122394886c658e0db30a6ba91d751.tar.xz
testing/paper-icon-theme: move to community
Diffstat (limited to 'community/paper-icon-theme')
-rw-r--r--community/paper-icon-theme/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/community/paper-icon-theme/APKBUILD b/community/paper-icon-theme/APKBUILD
new file mode 100644
index 0000000000..d0de8ed6b1
--- /dev/null
+++ b/community/paper-icon-theme/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
+pkgname=paper-icon-theme
+pkgver=1.4.0
+pkgrel=0
+pkgdesc="Paper is a modern freedesktop icon theme"
+url="http://snwh.org/paper"
+arch="noarch"
+license="CC-BY-SA-4.0"
+depends=""
+makedepends="automake autoconf libtool"
+install=""
+options="!strip"
+subpackages=""
+source="paper-icon-theme-$pkgver.tar.gz::https://github.com/snwh/paper-icon-theme/archive/v$pkgver.tar.gz"
+builddir="$srcdir/paper-icon-theme-$pkgver"
+
+build() {
+ cd "$builddir"
+ autoreconf -vif
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="076e1dfa1bc5928f4c6616ffd933926a paper-icon-theme-1.4.0.tar.gz"
+sha256sums="b90f3a84634572bcba76cdd0c2a0d305a5c521c2054d3d390edffda5f233928b paper-icon-theme-1.4.0.tar.gz"
+sha512sums="8089a926d61d22fea9f5145ae383e1558c792bd4bf0dc4b74b1bab0b6bfae987275512ec54e7d966fb18329804470f08759205ad0270624a0243a0394b1d0727 paper-icon-theme-1.4.0.tar.gz"