aboutsummaryrefslogtreecommitdiffstats
path: root/community/pcre2
diff options
context:
space:
mode:
authorTuan M. Hoang <tmhoang@flatglobe.org>2017-04-11 21:00:16 -0400
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-04-20 13:37:12 +0000
commitb4b148c538b071d0922877ff6e3369434382dc37 (patch)
tree730770c3ed258f1e346b6d1f6f0f4d24931f2b8d /community/pcre2
parent286982fe487f3a33c9a8195b19848a9c4f28e609 (diff)
downloadaports-b4b148c538b071d0922877ff6e3369434382dc37.tar.bz2
aports-b4b148c538b071d0922877ff6e3369434382dc37.tar.xz
community/pcre2: disable jit on s390x
Diffstat (limited to 'community/pcre2')
-rw-r--r--community/pcre2/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/community/pcre2/APKBUILD b/community/pcre2/APKBUILD
index 7a892dede2..a0109666e3 100644
--- a/community/pcre2/APKBUILD
+++ b/community/pcre2/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=pcre2
pkgver=10.23
-pkgrel=0
+pkgrel=1
pkgdesc="Perl-compatible regular expression library"
url="http://pcre.sourceforge.net/"
arch="all"
@@ -19,6 +19,7 @@ build() {
cd "$builddir"
# Note: Forced -O3 is recommended (needed?) for Julia.
+ [ "$CARCH" != "s390x" ] && _enable_jit="--enable-jit"
./configure \
CFLAGS="$CFLAGS -O3" \
--build=$CBUILD \
@@ -28,11 +29,10 @@ build() {
--htmldir=/usr/share/doc/$pkgname-$pkgver/html \
--enable-pcre2-16 \
--enable-pcre2-32 \
- --enable-jit \
--enable-pcre2grep-libz \
--enable-pcre2test-libedit \
--with-match-limit-recursion=8192 \
- || return 1
+ $_enable_jit
make
}