aboutsummaryrefslogtreecommitdiffstats
path: root/community/pdns
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2019-10-07 13:03:46 -0400
committerKevin Daudt <kdaudt@alpinelinux.org>2019-10-07 19:24:23 +0000
commit25f20f979861244732e06338c28e2b24f1f2d9ee (patch)
treebbf3451fbc581809b21ca8dab262cdc8337aceed /community/pdns
parent82c1249bade7d55fb33947c6427d0f9e377ef438 (diff)
downloadaports-25f20f979861244732e06338c28e2b24f1f2d9ee.tar.bz2
aports-25f20f979861244732e06338c28e2b24f1f2d9ee.tar.xz
community/pdns: match .sql file path
Closes !296
Diffstat (limited to 'community/pdns')
-rw-r--r--community/pdns/APKBUILD5
-rw-r--r--community/pdns/pdns-backend-pgsql.post-upgrade2
2 files changed, 4 insertions, 3 deletions
diff --git a/community/pdns/APKBUILD b/community/pdns/APKBUILD
index de12937b71..5e9371f97e 100644
--- a/community/pdns/APKBUILD
+++ b/community/pdns/APKBUILD
@@ -7,7 +7,7 @@
# Maintainer: Matt Smith <mcs@darkregion.net>
pkgname=pdns
pkgver=4.2.0
-pkgrel=0
+pkgrel=1
pkgdesc="PowerDNS Authoritative Server"
url="https://www.powerdns.com/"
arch="all !s390x"
@@ -83,7 +83,8 @@ package() {
"$pkgdir/etc/$pkgname/$pkgname.conf"
chown pdns:pdns "$pkgdir/etc/$pkgname/$pkgname.conf"
- cp -p "$pkgdir/usr/share/doc/pdns/4.1.0_to_4.2.0_schema.pgsql.sql" "$pkgdir/etc/$pkgname/"
+ # pdns-backend-pgsql.post-upgrade needs to be updated when this file path changes
+ cp -v -p "$pkgdir/usr/share/doc/pdns/4.1.0_to_4.2.0_schema.pgsql.sql" "$pkgdir/etc/$pkgname/"
}
tools() {
diff --git a/community/pdns/pdns-backend-pgsql.post-upgrade b/community/pdns/pdns-backend-pgsql.post-upgrade
index bd3dc67bdc..c41fb24586 100644
--- a/community/pdns/pdns-backend-pgsql.post-upgrade
+++ b/community/pdns/pdns-backend-pgsql.post-upgrade
@@ -1,6 +1,6 @@
#!/bin/sh
-schema_file='/etc/pdns/4.1.10_to_4.1.11.schema.pgsql.sql'
+schema_file='/etc/pdns/4.1.0_to_4.2.0_schema.pgsql.sql'
configs() {
find /etc/pdns -name pdns.conf -print -o -name 'pdns-*.conf' -print