aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-algorithm-diff-xs
diff options
context:
space:
mode:
authorTimothy Legge <timlegge@gmail.com>2020-02-25 22:45:32 +0000
committerAriadne Conill <ariadne@dereferenced.org>2020-02-27 00:03:26 +0000
commitc4c8e93635190a83e1bc0d44cb980e925a38c2e8 (patch)
tree3ae77736ae0b22a1cda8a0dafd52dd6ca87d94eb /community/perl-algorithm-diff-xs
parentfd8eb9a7cc30892bd27484e7020c4a53c67d8589 (diff)
downloadaports-c4c8e93635190a83e1bc0d44cb980e925a38c2e8.tar.bz2
aports-c4c8e93635190a83e1bc0d44cb980e925a38c2e8.tar.xz
community/perl-algorithm-diff-xs: move from testing
Diffstat (limited to 'community/perl-algorithm-diff-xs')
-rw-r--r--community/perl-algorithm-diff-xs/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/perl-algorithm-diff-xs/APKBUILD b/community/perl-algorithm-diff-xs/APKBUILD
new file mode 100644
index 0000000000..a26316ead6
--- /dev/null
+++ b/community/perl-algorithm-diff-xs/APKBUILD
@@ -0,0 +1,34 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-algorithm-diff-xs
+_pkgreal=Algorithm-Diff-XS
+pkgver=0.04
+pkgrel=3
+pkgdesc="Algorithm::Diff with XS core loop"
+url="https://metacpan.org/release/Algorithm-Diff-XS/"
+arch="all"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl-algorithm-diff"
+makedepends="perl-dev"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/A/AU/AUDREYT/Algorithm-Diff-XS-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="65f2e08129b90e61c3e90156ee3a7683268d86896599b68ca401ed6a93685933f88a40442b7328b47b4ad0f0c4a407e472175586a5497cd7026e4448d4f116f1 Algorithm-Diff-XS-0.04.tar.gz"