aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-algorithm-diff
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-27 18:58:52 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-27 18:58:52 +0100
commit54806a23f6391c780ee6095f8cf87986fd68cf44 (patch)
treeac3e55e1a9a66d2e89132cbbe1cfc2a007b27077 /community/perl-algorithm-diff
parent5b53da70318e51af99c47d339c8cf48215f8711f (diff)
downloadaports-54806a23f6391c780ee6095f8cf87986fd68cf44.tar.bz2
aports-54806a23f6391c780ee6095f8cf87986fd68cf44.tar.xz
community/perl-algorithm-diff: fix url=, source= and license=
Diffstat (limited to 'community/perl-algorithm-diff')
-rw-r--r--community/perl-algorithm-diff/APKBUILD16
1 files changed, 5 insertions, 11 deletions
diff --git a/community/perl-algorithm-diff/APKBUILD b/community/perl-algorithm-diff/APKBUILD
index cfc36dc01c..38b163a75a 100644
--- a/community/perl-algorithm-diff/APKBUILD
+++ b/community/perl-algorithm-diff/APKBUILD
@@ -4,38 +4,32 @@
pkgname=perl-algorithm-diff
_pkgreal=Algorithm-Diff
pkgver=1.1903
-pkgrel=1
+pkgrel=2
pkgdesc="Compute 'intelligent' differences between two files / lists"
-url="http://search.cpan.org/dist/Algorithm-Diff/"
+url="https://metacpan.org/release/Algorithm-Diff"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends=""
-cpanmakedepends=""
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/T/TY/TYEMQ/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/T/TY/TYEMQ/Algorithm-Diff-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
default_prepare
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$builddir"
make
}
check() {
- cd "$builddir"
- make test
+ make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}