aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-authen-ntlm
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-27 19:05:44 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-27 19:05:44 +0100
commit94a708b1e2e81ed8b7ec5dedeace8d5d96bc88e2 (patch)
tree37ed7b7a415564a6d6a23166b200bf959eaff32a /community/perl-authen-ntlm
parent4e20b8264d5d14e8bfed92f33eba9c809b161099 (diff)
downloadaports-94a708b1e2e81ed8b7ec5dedeace8d5d96bc88e2.tar.bz2
aports-94a708b1e2e81ed8b7ec5dedeace8d5d96bc88e2.tar.xz
community/perl-authen-ntlm: fix url=,source= and license=
Diffstat (limited to 'community/perl-authen-ntlm')
-rw-r--r--community/perl-authen-ntlm/APKBUILD17
1 files changed, 6 insertions, 11 deletions
diff --git a/community/perl-authen-ntlm/APKBUILD b/community/perl-authen-ntlm/APKBUILD
index 4b52a7bc22..49f8630797 100644
--- a/community/perl-authen-ntlm/APKBUILD
+++ b/community/perl-authen-ntlm/APKBUILD
@@ -3,34 +3,29 @@
pkgname=perl-authen-ntlm
pkgver=1.09
_realname=NTLM-$pkgver
-pkgrel=1
+pkgrel=2
pkgdesc="NTLM authentication for Mail::IMAPClient"
-url="http://search.cpan.org/dist/NTLM/"
+url="https://metacpan.org/release/NTLM"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends=""
-cpanmakedepends=""
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl"
+makedepends="perl-dev"
checkdepends="perl-digest-hmac"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/N/NB/NBEBOUT/$_realname.tar.gz"
+source="https://cpan.metacpan.org/authors/id/N/NB/NBEBOUT/NTLM-$pkgver.tar.gz"
builddir="$srcdir/$_realname"
build() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}