aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-business-ismn
diff options
context:
space:
mode:
authorTimothy Legge <timlegge@gmail.com>2020-04-04 18:01:26 +0000
committerTBK <tbk@jjtc.eu>2020-04-05 17:00:47 +0000
commit0995bf8f1cdc26cc4316372f95ac8d411ed4c645 (patch)
tree3896e32ebe8b7b8dd96438c1727bababb3b7576d /community/perl-business-ismn
parent6c1807514a0c5b166765f995a9f5cc4769b065b5 (diff)
downloadaports-0995bf8f1cdc26cc4316372f95ac8d411ed4c645.tar.bz2
aports-0995bf8f1cdc26cc4316372f95ac8d411ed4c645.tar.xz
community/perl-business-ismn: modernize APKBUILD
Diffstat (limited to 'community/perl-business-ismn')
-rw-r--r--community/perl-business-ismn/APKBUILD29
1 files changed, 9 insertions, 20 deletions
diff --git a/community/perl-business-ismn/APKBUILD b/community/perl-business-ismn/APKBUILD
index e52003a070..9c19cf9e3f 100644
--- a/community/perl-business-ismn/APKBUILD
+++ b/community/perl-business-ismn/APKBUILD
@@ -1,44 +1,33 @@
-# Automatically generated by apkbuild-cpan, template 1
+# Automatically generated by apkbuild-cpan, template 3
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-business-ismn
+#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=Business-ISMN
pkgver=1.201
-pkgrel=1
+pkgrel=2
pkgdesc="Work with International Standard Music Numbers"
url="https://metacpan.org/release/Business-ISMN/"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends="perl-tie-cycle"
-checkdepends="perl-test-pod perl-test-pod-coverage"
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+license="Artistic-2.0"
+depends="perl perl-tie-cycle"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
-source="https://cpan.metacpan.org/authors/id/B/BD/BDFOY/$_pkgreal-$pkgver.tar.gz"
-
+source="https://cpan.metacpan.org/authors/id/B/BD/BDFOY/Business-ISMN-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- default_prepare
-
- cd "$builddir"
- export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
-}
-
build() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}