aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-common-sense/APKBUILD
diff options
context:
space:
mode:
authorTaner Tas <taner76@gmail.com>2019-04-27 23:34:44 +0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-27 21:02:51 +0000
commit15ccd0f5a2e366ed805123e8857b6abdc4bffdd4 (patch)
tree94ff789e3ee452a4b5ad4f20100d5878717c1b23 /community/perl-common-sense/APKBUILD
parent92ae64f9103d96d1890be819d0d5bd784eeb6854 (diff)
downloadaports-15ccd0f5a2e366ed805123e8857b6abdc4bffdd4.tar.bz2
aports-15ccd0f5a2e366ed805123e8857b6abdc4bffdd4.tar.xz
community/perl-common-sense: move from testing
Closes GH-6354
Diffstat (limited to 'community/perl-common-sense/APKBUILD')
-rw-r--r--community/perl-common-sense/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/perl-common-sense/APKBUILD b/community/perl-common-sense/APKBUILD
new file mode 100644
index 0000000000..1879b96a28
--- /dev/null
+++ b/community/perl-common-sense/APKBUILD
@@ -0,0 +1,33 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor:
+# Maintainer:
+pkgname=perl-common-sense
+_pkgreal=common-sense
+pkgver=3.74
+pkgrel=0
+pkgdesc="Implementation of sane defaults for Perl programs"
+url="https://metacpan.org/release/common-sense"
+arch="noarch"
+license="GPL-1.0-or-later Artistic-1.0-Perl"
+depends="perl"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/M/ML/MLEHMANN/common-sense-$pkgver.tar.gz"
+
+builddir="$srcdir"/$_pkgreal-$pkgver
+
+build() {
+ cd "$builddir"
+ perl Makefile.PL INSTALLDIRS=vendor
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="658ad70a2d1bbd0b26f91c4ea5d69b4cc0b632ede9532b88282987002a5e280f0475d63ee846b7bd2d38ef82f2680e20c2093803e4b62a984750ed447f318d60 common-sense-3.74.tar.gz"