aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-dist-checkconflicts/APKBUILD
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-19 09:13:22 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-19 11:24:36 +0000
commitf18c03be138cdf19cfc175560bcfed4bafc3f3c9 (patch)
tree8ac1ffd3ca09bc1cface421d4163ba122e3435c7 /community/perl-dist-checkconflicts/APKBUILD
parent5c2205003cdfe5455c803b1cd8ce632424662f16 (diff)
downloadaports-f18c03be138cdf19cfc175560bcfed4bafc3f3c9.tar.bz2
aports-f18c03be138cdf19cfc175560bcfed4bafc3f3c9.tar.xz
community/perl-dist-checkconflicts: moved from testing
Diffstat (limited to 'community/perl-dist-checkconflicts/APKBUILD')
-rw-r--r--community/perl-dist-checkconflicts/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/community/perl-dist-checkconflicts/APKBUILD b/community/perl-dist-checkconflicts/APKBUILD
new file mode 100644
index 0000000000..fa4b814e1b
--- /dev/null
+++ b/community/perl-dist-checkconflicts/APKBUILD
@@ -0,0 +1,41 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=perl-dist-checkconflicts
+_pkgreal=Dist-CheckConflicts
+pkgver=0.11
+pkgrel=0
+pkgdesc="declare version conflicts for your dist"
+url="http://search.cpan.org/dist/Dist-CheckConflicts/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-list-moreutils perl-module-runtime"
+cpanmakedepends=" perl-test-fatal "
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/D/DO/DOY/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="c8725a92b9169708b0f63036812070f2 Dist-CheckConflicts-0.11.tar.gz"
+sha256sums="ea844b9686c94d666d9d444321d764490b2cde2f985c4165b4c2c77665caedc4 Dist-CheckConflicts-0.11.tar.gz"
+sha512sums="6c3f8546c1c7904bbc2a3c1135d145cbff95997c3032e9129afc98bdd98578dd9219af444f357dd8e9b1f08442a2fdd9d6f7fe8768f8ef165e71570f5ae246ad Dist-CheckConflicts-0.11.tar.gz"