aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-email-mime
diff options
context:
space:
mode:
authorTimothy Legge <timlegge@gmail.com>2020-02-20 23:19:12 +0000
committerLeo <thinkabit.ukim@gmail.com>2020-02-21 10:34:17 -0300
commita89e888ae51456d3c49eb73526ae1921d265a50c (patch)
tree691055fedfc37ae443b62fe874726cbbd3a2c1f4 /community/perl-email-mime
parent751776534a3d085b53671d1b69f48de77c365232 (diff)
downloadaports-a89e888ae51456d3c49eb73526ae1921d265a50c.tar.bz2
aports-a89e888ae51456d3c49eb73526ae1921d265a50c.tar.xz
community/perl-email-mime: fix missing dependancy and modernize
Diffstat (limited to 'community/perl-email-mime')
-rw-r--r--community/perl-email-mime/APKBUILD20
1 files changed, 7 insertions, 13 deletions
diff --git a/community/perl-email-mime/APKBUILD b/community/perl-email-mime/APKBUILD
index f84bd5ae9d..6f5d1f0deb 100644
--- a/community/perl-email-mime/APKBUILD
+++ b/community/perl-email-mime/APKBUILD
@@ -4,41 +4,35 @@
pkgname=perl-email-mime
_pkgreal=Email-MIME
pkgver=1.946
-pkgrel=1
+pkgrel=2
pkgdesc="easy MIME message handling"
url="https://metacpan.org/release/Email-MIME/"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends="perl-email-mime-contenttype perl-email-mime-encodings
+license="GPL-1.0-or-later Artistic-1.0-Perl"
+depends="perl-email-mime-contenttype perl-email-mime-encodings
perl-email-simple perl-email-address perl-email-messageid perl-mime-types
-perl-module-runtime"
-cpanmakedepends=" "
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+perl-email-address-xs perl-module-runtime"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/R/RJ/RJBS/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
check() {
- cd "$builddir"
make test
}
prepare() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}