aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-function-parameters
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-11-23 08:27:44 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-11-23 08:29:17 +0000
commita54bb1119e1a5a4162ed4940132b75d118a141b4 (patch)
treeb8d20512eb24ed24597a402d4735a4765587a3d1 /community/perl-function-parameters
parentcfb425ec4617e8993d0ab54865b50d7499a4cbbe (diff)
downloadaports-a54bb1119e1a5a4162ed4940132b75d118a141b4.tar.bz2
aports-a54bb1119e1a5a4162ed4940132b75d118a141b4.tar.xz
community/perl-function-parameters: new aport. In community because of per-test-postgresql dependency
Diffstat (limited to 'community/perl-function-parameters')
-rw-r--r--community/perl-function-parameters/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/community/perl-function-parameters/APKBUILD b/community/perl-function-parameters/APKBUILD
new file mode 100644
index 0000000000..6abd90d985
--- /dev/null
+++ b/community/perl-function-parameters/APKBUILD
@@ -0,0 +1,42 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=perl-function-parameters
+_pkgreal=Function-Parameters
+pkgver=1.0705
+pkgrel=0
+pkgdesc="subroutine definitions with parameter lists"
+url="http://search.cpan.org/dist/Function-Parameters/"
+arch="all"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends=" perl-dir-self perl-test-fatal "
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/M/MA/MAUKE/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ default_prepare || return 1
+
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make && make test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="fbaa61e7acb8e85e63a84b8b40ca2b5b Function-Parameters-1.0705.tar.gz"
+sha256sums="5dd904dc6511df6901260392ea98d39ebd178e1df195456357e91217229e8e03 Function-Parameters-1.0705.tar.gz"
+sha512sums="b58905730b2fa81bf607249d86c68a47d71b810aaca91a497974211bfe094b84c8cc6841eeee0a44e925cb8d632c8f7850365ac0bd194f37c1add081f19fa772 Function-Parameters-1.0705.tar.gz"