aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-ima-dbi
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-06-09 15:03:16 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-13 03:46:22 -0300
commit6aa1515f7b3e79ed32c615a8faddfe9bf40ff85c (patch)
tree2dd7107a0bdb8f72b1d4e6d1a6b0a74b46ce60aa /community/perl-ima-dbi
parenta69cfca0bceb692f4fab2a47de7c19e3ed3a584d (diff)
downloadaports-6aa1515f7b3e79ed32c615a8faddfe9bf40ff85c.tar.bz2
aports-6aa1515f7b3e79ed32c615a8faddfe9bf40ff85c.tar.xz
community/perl-ima-dbi: fix URL&License
* fix pkgdesc * modernize
Diffstat (limited to 'community/perl-ima-dbi')
-rw-r--r--community/perl-ima-dbi/APKBUILD29
1 files changed, 9 insertions, 20 deletions
diff --git a/community/perl-ima-dbi/APKBUILD b/community/perl-ima-dbi/APKBUILD
index da9e4e7bb5..b24b4255a9 100644
--- a/community/perl-ima-dbi/APKBUILD
+++ b/community/perl-ima-dbi/APKBUILD
@@ -4,39 +4,28 @@
pkgname=perl-ima-dbi
_pkgreal=Ima-DBI
pkgver=0.35
-pkgrel=2
-pkgdesc="unknown"
-url="http://search.cpan.org/dist/Ima-DBI/"
+pkgrel=3
+pkgdesc="Database connection caching and organization"
+url="https://metacpan.org/pod/Ima::DBI"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends="perl-dbi perl-class-data-inheritable perl-dbix-contextualfetch"
-cpanmakedepends="perl-test-pod perl-test-pod-coverage"
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl-dbi perl-class-data-inheritable perl-dbix-contextualfetch"
+makedepends="perl-dev perl-test-pod perl-test-pod-coverage"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/P/PE/PERRIN/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/P/PE/PERRIN/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- default_prepare
-
- cd "$builddir"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
-}
-
build() {
- cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
- make test
+ make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}