aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-import-into
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-19 09:27:50 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-19 11:24:37 +0000
commit90927b373133a1c8dc4376cd4be481087fd0bd0b (patch)
tree2a5518cb52c21c4054982ee9fa0e4a73858279cd /community/perl-import-into
parenteb02d58f4ed86a12e16b9a88a0d6c48479827974 (diff)
downloadaports-90927b373133a1c8dc4376cd4be481087fd0bd0b.tar.bz2
aports-90927b373133a1c8dc4376cd4be481087fd0bd0b.tar.xz
community/perl-import-into: moved from testing
Diffstat (limited to 'community/perl-import-into')
-rw-r--r--community/perl-import-into/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/community/perl-import-into/APKBUILD b/community/perl-import-into/APKBUILD
new file mode 100644
index 0000000000..23052fdd9a
--- /dev/null
+++ b/community/perl-import-into/APKBUILD
@@ -0,0 +1,41 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=perl-import-into
+_pkgreal=Import-Into
+pkgver=1.002005
+pkgrel=0
+pkgdesc="Import packages into other packages"
+url="http://search.cpan.org/dist/Import-Into/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-module-runtime"
+cpanmakedepends=" "
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/H/HA/HAARG/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="48bdc7988f5a7d4d06039ccc5c2459e9 Import-Into-1.002005.tar.gz"
+sha256sums="bd9e77a3fb662b40b43b18d3280cd352edf9fad8d94283e518181cc1ce9f0567 Import-Into-1.002005.tar.gz"
+sha512sums="d356307072da18bc40b25f11583018ed416cb87178f080982e14e98e53d42bc1e04aebda56d595e707c05065eaa6ad7a6b059920e8b5b8e1589bfd68e26900fb Import-Into-1.002005.tar.gz"