aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-import-into
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-06-09 14:59:53 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-13 03:47:17 -0300
commit03b5c4a5bd15d7860a6fb92d293213a306b306ca (patch)
treef9d819211a57cd0b6f1f6142de57fd1bcf357927 /community/perl-import-into
parent6aa1515f7b3e79ed32c615a8faddfe9bf40ff85c (diff)
downloadaports-03b5c4a5bd15d7860a6fb92d293213a306b306ca.tar.bz2
aports-03b5c4a5bd15d7860a6fb92d293213a306b306ca.tar.xz
community/perl-import-into: fix URL&License
* modernize
Diffstat (limited to 'community/perl-import-into')
-rw-r--r--community/perl-import-into/APKBUILD30
1 files changed, 9 insertions, 21 deletions
diff --git a/community/perl-import-into/APKBUILD b/community/perl-import-into/APKBUILD
index 499cbf2d17..66fd1c950d 100644
--- a/community/perl-import-into/APKBUILD
+++ b/community/perl-import-into/APKBUILD
@@ -4,41 +4,29 @@
pkgname=perl-import-into
_pkgreal=Import-Into
pkgver=1.002005
-pkgrel=1
+pkgrel=2
pkgdesc="Import packages into other packages"
-url="http://search.cpan.org/dist/Import-Into/"
+url="https://metacpan.org/pod/Import::Into"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends="perl-module-runtime"
-cpanmakedepends=""
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl perl-module-runtime"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/H/HA/HAARG/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/H/HA/HAARG/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- default_prepare
-
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
-}
-
build() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
- make test
+ make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}