aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-io-gzip
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-06-07 13:38:05 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-14 17:38:08 -0300
commitf16a4176cdef3ece55f6670819046db098a183de (patch)
treec95954556f5a423ebf0aa3533bc5ab360a348a85 /community/perl-io-gzip
parenta797221d60591d3304026af4a569f4df487fda61 (diff)
downloadaports-f16a4176cdef3ece55f6670819046db098a183de.tar.bz2
aports-f16a4176cdef3ece55f6670819046db098a183de.tar.xz
community/perl-io-gzip: fix URL&License
* modernize
Diffstat (limited to 'community/perl-io-gzip')
-rw-r--r--community/perl-io-gzip/APKBUILD17
1 files changed, 7 insertions, 10 deletions
diff --git a/community/perl-io-gzip/APKBUILD b/community/perl-io-gzip/APKBUILD
index 23253fd657..a3e2e1766c 100644
--- a/community/perl-io-gzip/APKBUILD
+++ b/community/perl-io-gzip/APKBUILD
@@ -2,31 +2,28 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-io-gzip
pkgver=0.20
-pkgrel=2
+pkgrel=3
pkgdesc="Perl extension to provide a PerlIO layer to gzip/gunzip"
-url="http://search.cpan.org/dist/PerlIO-gzip/"
+url="https://metacpan.org/pod/IO::Compress::Gzip"
arch="all"
-license="GPL"
-depends_dev="perl-dev zlib-dev"
-makedepends="$depends_dev"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl"
+makedepends="perl-dev zlib-dev"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/N/NW/NWCLARK/PerlIO-gzip-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/N/NW/NWCLARK/PerlIO-gzip-$pkgver.tar.gz"
builddir="$srcdir/PerlIO-gzip-$pkgver"
build() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
- make test
+ make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}