aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-ipc-run
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-06-07 13:01:32 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-14 17:34:55 -0300
commit46ef93178955f18f217fffc17a6ffa2833a350f0 (patch)
tree1b7d51e896d220694933ac019ba9c583468da6fd /community/perl-ipc-run
parentdc0395684c4bdbc735d5867b8157d10c7c0e64f8 (diff)
downloadaports-46ef93178955f18f217fffc17a6ffa2833a350f0.tar.bz2
aports-46ef93178955f18f217fffc17a6ffa2833a350f0.tar.xz
community/perl-ipc-run: fix URL&License
* modernize
Diffstat (limited to 'community/perl-ipc-run')
-rw-r--r--community/perl-ipc-run/APKBUILD17
1 files changed, 6 insertions, 11 deletions
diff --git a/community/perl-ipc-run/APKBUILD b/community/perl-ipc-run/APKBUILD
index 17290611ac..0dd3cf298f 100644
--- a/community/perl-ipc-run/APKBUILD
+++ b/community/perl-ipc-run/APKBUILD
@@ -4,36 +4,31 @@
pkgname=perl-ipc-run
_pkgreal=IPC-Run
pkgver=20180523.0
-pkgrel=0
+pkgrel=1
pkgdesc="system() and background procs w/ piping, redirs, ptys (Unix, Win32)"
-url="http://search.cpan.org/dist/IPC-Run/"
+url="https://metacpan.org/pod/IPC::Run"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends="perl-io-tty"
-depends="$cpandepends"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl-io-tty"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/T/TO/TODDR/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/T/TO/TODDR/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
check() {
- cd "$builddir"
make test
}
build() {
- cd "$builddir"
make
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}