aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-module-install-authorrequires/APKBUILD
diff options
context:
space:
mode:
authorTimothy Legge <timlegge@gmail.com>2020-02-26 02:04:52 +0000
committerAriadne Conill <ariadne@dereferenced.org>2020-02-27 00:03:26 +0000
commit2f1c94bad69d98490220252e69e0b7920526dfd9 (patch)
treef6c5dd6404520b398ef20f60d3338eccc659ad10 /community/perl-module-install-authorrequires/APKBUILD
parentc4c8e93635190a83e1bc0d44cb980e925a38c2e8 (diff)
downloadaports-2f1c94bad69d98490220252e69e0b7920526dfd9.tar.bz2
aports-2f1c94bad69d98490220252e69e0b7920526dfd9.tar.xz
community/perl-module-install-authorrequires: move from testing
Diffstat (limited to 'community/perl-module-install-authorrequires/APKBUILD')
-rw-r--r--community/perl-module-install-authorrequires/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/perl-module-install-authorrequires/APKBUILD b/community/perl-module-install-authorrequires/APKBUILD
new file mode 100644
index 0000000000..3ddbc57d93
--- /dev/null
+++ b/community/perl-module-install-authorrequires/APKBUILD
@@ -0,0 +1,34 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-module-install-authorrequires
+_pkgreal=Module-Install-AuthorRequires
+pkgver=0.02
+pkgrel=0
+pkgdesc="declare author-only dependencies"
+url="https://metacpan.org/release/Module-Install-AuthorRequires/"
+arch="noarch"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl-module-install"
+makedepends="perl-dev"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/F/FL/FLORA/Module-Install-AuthorRequires-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="66d2a603e5700eca0a93523b6adcd0330d439b41730b7ccb2606fc4e43e4b6620cf376637fcbbe71d4733ce144c46822fecac39d4bed3d5303b68863425d9819 Module-Install-AuthorRequires-0.02.tar.gz"