aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-module-install/APKBUILD
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-04-05 06:21:02 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-04-05 06:21:02 +0000
commitf722452592408ea345c5b9288a99e8ee47354848 (patch)
tree80a6f2e9ade2a79ea15c72880a0d6af734c7e8ef /community/perl-module-install/APKBUILD
parentbe5d2583763c627f77ad2deeff517929fb9ca63c (diff)
downloadaports-f722452592408ea345c5b9288a99e8ee47354848.tar.bz2
aports-f722452592408ea345c5b9288a99e8ee47354848.tar.xz
community/perl-module-install: upgrade to 1.18, modernize APKBUILD
Diffstat (limited to 'community/perl-module-install/APKBUILD')
-rw-r--r--community/perl-module-install/APKBUILD29
1 files changed, 13 insertions, 16 deletions
diff --git a/community/perl-module-install/APKBUILD b/community/perl-module-install/APKBUILD
index 366e300c01..4ff632968a 100644
--- a/community/perl-module-install/APKBUILD
+++ b/community/perl-module-install/APKBUILD
@@ -2,42 +2,39 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-module-install
_pkgreal=Module-Install
-pkgver=1.17
+pkgver=1.18
pkgrel=0
pkgdesc="Perl module for Module-Install"
url="http://search.cpan.org/dist/Module-Install/"
arch="noarch"
license="GPL PerlArtistic"
-cpandepends=""
cpanmakedepends="perl-file-remove perl-module-build perl-module-scandeps perl-yaml-tiny"
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/E/ET/ETHER/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+check() {
+ cd "$builddir"
+ make test
+}
prepare() {
- cd "$_builddir"
- if [ -e Build.PL ]; then
- perl Build.PL installdirs=vendor || return 1
- else
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- fi
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="39da11e45b32f79f66823015d3be4153 Module-Install-1.17.tar.gz"
-sha256sums="bc1365cf447fc8e09ef002f68e0a2ac3ace071ebf412c94a2cd08ddae6e17065 Module-Install-1.17.tar.gz"
-sha512sums="e7f71ece28518d490aa9f038f24e88c81722239bb065a56e0414013646940d7326838579347d030a30b6e3a3d7810f7432d0c2a27560147bc4545e6884c27f91 Module-Install-1.17.tar.gz"
+sha512sums="2126d35c9bab151548551629e6a470f9a7b90fd901f32cdc15e9aa83b931178f99e28e2de32ce7b8a677d187474efc428839d7e7254074f26fcfcfe18fa297a9 Module-Install-1.18.tar.gz"