aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-mojolicious
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-04-25 06:38:08 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-04-25 07:44:50 +0000
commit07ee8e47ccd39730201eb180a51d68e4d5aab137 (patch)
treecaa086db4f1ee0492885bdb4724d0e280990190f /community/perl-mojolicious
parent4a9867eaf898b06725fbcde8873fd1fce9cc2a27 (diff)
downloadaports-07ee8e47ccd39730201eb180a51d68e4d5aab137.tar.bz2
aports-07ee8e47ccd39730201eb180a51d68e4d5aab137.tar.xz
community/perl-mojolicious: added check(), modernize APKBUILD
Diffstat (limited to 'community/perl-mojolicious')
-rw-r--r--community/perl-mojolicious/APKBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/community/perl-mojolicious/APKBUILD b/community/perl-mojolicious/APKBUILD
index a311bc2dcc..283f77da05 100644
--- a/community/perl-mojolicious/APKBUILD
+++ b/community/perl-mojolicious/APKBUILD
@@ -17,9 +17,14 @@ subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/S/SR/SRI/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
-prepare() {
- default_prepare || return 1
+check() {
+ cd "$builddir"
+ make test
+}
+
+prepare() {
+ default_prepare
cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
@@ -28,12 +33,12 @@ prepare() {
build() {
cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- make && make test
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}