aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-sort-key
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-05 13:07:06 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-05 13:31:30 +0000
commit3ce302210e5b0a911d9657215d691b8fe4e5b9b5 (patch)
tree778ae8d17fb65f669c60b8d5eeeb3aa43bb87d58 /community/perl-sort-key
parenta439676586c0e22b38559c0cfb70d81123930b3a (diff)
downloadaports-3ce302210e5b0a911d9657215d691b8fe4e5b9b5.tar.bz2
aports-3ce302210e5b0a911d9657215d691b8fe4e5b9b5.tar.xz
community/perl-[n-s]*: modernize APKBUILD
Changes: - Move tests to check() - Remove return 1 - rename _builddir to builddir - add missing default_prepare in prepare()
Diffstat (limited to 'community/perl-sort-key')
-rw-r--r--community/perl-sort-key/APKBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/community/perl-sort-key/APKBUILD b/community/perl-sort-key/APKBUILD
index dac15a64ab..b4c42dc82a 100644
--- a/community/perl-sort-key/APKBUILD
+++ b/community/perl-sort-key/APKBUILD
@@ -4,13 +4,13 @@
pkgname=perl-sort-key
_pkgreal=Sort-Key
pkgver=1.33
-pkgrel=1
+pkgrel=2
pkgdesc="the fastest way to sort anything in Perl"
url="http://search.cpan.org/dist/Sort-Key/"
arch="all"
license="GPL PerlArtistic"
cpandepends=""
-cpanmakedepends=" "
+cpanmakedepends=""
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
@@ -18,7 +18,7 @@ source="http://search.cpan.org/CPAN/authors/id/S/SA/SALVA/$_pkgreal-$pkgver.tar.
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- default_prepare || return 1
+ default_prepare
cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
@@ -28,15 +28,18 @@ prepare() {
build() {
cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="a37ab0da0cfdc26e57b4c79e39f6d98f Sort-Key-1.33.tar.gz"
-sha256sums="ed6a4ccfab094c9cd164f564024e98bd21d94f4312ccac4d6246d22b34081acf Sort-Key-1.33.tar.gz"
sha512sums="cf87cd2f5c0eea662dbdaf7faed5646ebd63925c71a093a79a9980d6de290b1128443954675893f263961e68d1db0e9e4ca1412a2734ce8dcdd271bcf4f1be17 Sort-Key-1.33.tar.gz"