aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-test-most
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-04 05:32:04 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-04 08:51:24 +0000
commita0463c4faa336561a065e3d44f13ba4c468796e0 (patch)
tree49fcb10670b2b57bc78504dd44f0457c75784ea8 /community/perl-test-most
parentc955b69f53c14a9de0b5496ce974c5b4b25b6802 (diff)
downloadaports-a0463c4faa336561a065e3d44f13ba4c468796e0.tar.bz2
aports-a0463c4faa336561a065e3d44f13ba4c468796e0.tar.xz
community/perl-test-most: upgrade to 0.36
Diffstat (limited to 'community/perl-test-most')
-rw-r--r--community/perl-test-most/APKBUILD23
1 files changed, 9 insertions, 14 deletions
diff --git a/community/perl-test-most/APKBUILD b/community/perl-test-most/APKBUILD
index 4e2ae9b2ee..3c3177e41c 100644
--- a/community/perl-test-most/APKBUILD
+++ b/community/perl-test-most/APKBUILD
@@ -2,42 +2,37 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=perl-test-most
_pkgreal=Test-Most
-pkgver=0.35
-pkgrel=3
+pkgver=0.36
+pkgrel=0
pkgdesc="Most commonly needed test functions and features"
url="https://metacpan.org/release/Test-Most/"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends="perl-exception-class perl-test-differences perl-test-warn perl-test-exception perl-test-deep"
-cpanmakedepends=" "
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl perl-exception-class perl-test-differences perl-test-warn
+ perl-test-exception perl-test-deep"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/O/OV/OVID/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="1b2d201811e59d7afce47ff5f7da67c170d4685ffbec23360757b5cacc9fe72fc82609bc46cc9d8e351fdb75715696457c201dd94fadaeca70a6f31690236291 Test-Most-0.35.tar.gz"
+sha512sums="86aeba1865f0788c5314518a21b301f29195f849f226601f32b9534900db7766e5ff2737c908de3287000742743d025783ab7a0b59dd8dce3ffc31f1f0538f46 Test-Most-0.36.tar.gz"