aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-test-nginx/APKBUILD
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2019-05-02 08:29:19 +0300
committerTimo Teräs <timo.teras@iki.fi>2019-05-02 08:29:19 +0300
commit964f6850901f999df3aa15e3dc30a252348e44df (patch)
treed11d350211f46b4360ad6d01cdabe70b37436f72 /community/perl-test-nginx/APKBUILD
parent71ba6826210f553d7dc22a5c8b0faf87b9e1f37a (diff)
downloadaports-964f6850901f999df3aa15e3dc30a252348e44df.tar.bz2
aports-964f6850901f999df3aa15e3dc30a252348e44df.tar.xz
community/perl-test-nginx: moved from testing
Diffstat (limited to 'community/perl-test-nginx/APKBUILD')
-rw-r--r--community/perl-test-nginx/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/community/perl-test-nginx/APKBUILD b/community/perl-test-nginx/APKBUILD
new file mode 100644
index 0000000000..ed4b073c8f
--- /dev/null
+++ b/community/perl-test-nginx/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=perl-test-nginx
+_pkgreal=Test-Nginx
+pkgver=0.26
+pkgrel=0
+pkgdesc="Data-driven test scaffold for Nginx C module and Nginx/OpenResty-based libraries and applications"
+url="https://github.com/openresty/test-nginx"
+arch="noarch"
+license="BSD"
+depends="perl perl-list-moreutils perl-http-message perl-test-longstring
+ perl-text-diff perl-libwww perl-uri perl-test-base"
+makedepends="perl-dev"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/A/AG/AGENT/$_pkgreal-$pkgver.tar.gz
+ set-temp-paths.patch"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ default_prepare
+
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$builddir"
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
+package() {
+ cd "$builddir"
+
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="8f5f244d98a20e9a125b2fb56753e77eb3f4a3390f01d46e9e565ef4cb2667725421322cda7ac3933f1fcb6f7863477769c18797cbe7b3eb3f7398590593fd01 Test-Nginx-0.26.tar.gz
+028133884a4cba921ee9533fd0d53d1c65a0cbce93c9b81ffbe4004aaed6cdeb2a5327824d4b0cefe0902ba8c9e9f2a7efed65869db3f0733a36f9a4c56bbed9 set-temp-paths.patch"