aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-test-without-module
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-19 09:04:21 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-19 11:24:36 +0000
commitc0280255116150f995bf22eb5c641e0e383440b7 (patch)
tree69405f784ab6d7d00c6db1bb8ac6be35e541638d /community/perl-test-without-module
parent3f644060947ea52736c5364cb3cf2cd4c9b2e0e9 (diff)
downloadaports-c0280255116150f995bf22eb5c641e0e383440b7.tar.bz2
aports-c0280255116150f995bf22eb5c641e0e383440b7.tar.xz
community/perl-test-without-module: moved from testing
Diffstat (limited to 'community/perl-test-without-module')
-rw-r--r--community/perl-test-without-module/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/community/perl-test-without-module/APKBUILD b/community/perl-test-without-module/APKBUILD
new file mode 100644
index 0000000000..4b6b368ee9
--- /dev/null
+++ b/community/perl-test-without-module/APKBUILD
@@ -0,0 +1,41 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=perl-test-without-module
+_pkgreal=Test-Without-Module
+pkgver=0.18
+pkgrel=0
+pkgdesc="Test fallback behaviour in absence of modules"
+url="http://search.cpan.org/dist/Test-Without-Module/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends=" "
+depends="$cpandepends"
+makedepends="perl-dev perl-test-pod perl-file-slurp $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/C/CO/CORION/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="cd19ad26024e89fdfefb0ae0334ee500 Test-Without-Module-0.18.tar.gz"
+sha256sums="e2c3360b171d7db518ac39a0e1dcb285c784ea393c11708914a0655d66138c7f Test-Without-Module-0.18.tar.gz"
+sha512sums="005ad54ac77283cf3155befe77fdb887dbc2ebc9c154472a23982636bbe7728154f56fdf1990b833639cd687b38e4d62250edd6dd93d37408e971bb4bd49c4c2 Test-Without-Module-0.18.tar.gz"