aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-text-diff
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-27 20:35:40 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-27 20:35:40 +0100
commit216853c74c6d9f8548c043fc4b424eb4b373dce2 (patch)
tree5e832f9da579b67bc64446dd4c802c6a52fcdeb4 /community/perl-text-diff
parent45af3cfdaa663e6ffa99e6210e5467b4dbd3e562 (diff)
downloadaports-216853c74c6d9f8548c043fc4b424eb4b373dce2.tar.bz2
aports-216853c74c6d9f8548c043fc4b424eb4b373dce2.tar.xz
community/perl-text-diff: modernize
Diffstat (limited to 'community/perl-text-diff')
-rw-r--r--community/perl-text-diff/APKBUILD20
1 files changed, 7 insertions, 13 deletions
diff --git a/community/perl-text-diff/APKBUILD b/community/perl-text-diff/APKBUILD
index 2b25867abd..70eb913542 100644
--- a/community/perl-text-diff/APKBUILD
+++ b/community/perl-text-diff/APKBUILD
@@ -4,37 +4,31 @@
pkgname=perl-text-diff
_pkgreal=Text-Diff
pkgver=1.45
-pkgrel=1
+pkgrel=2
pkgdesc="Perform diffs on files and record sets"
-url="http://search.cpan.org/dist/Text-Diff/"
+url="https://metacpan.org/release/Text-Diff"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends="perl-algorithm-diff"
-cpanmakedepends=""
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+depends="perl-algorithm-diff"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/N/NE/NEILB/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/N/NE/NEILB/Text-Diff-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$builddir"
make
}
check() {
- cd "$builddir"
- make test
+ make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}