aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-text-roman
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-05 01:16:36 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-05 01:39:35 +0000
commitb1274f164d3742fc5a47f4ab85a91baef72338ec (patch)
tree7095e084822242b5cff89ac35bb3dee624642067 /community/perl-text-roman
parent4c6f8e1fdf89d2899b81dd6a680a65e89e20b7a9 (diff)
downloadaports-b1274f164d3742fc5a47f4ab85a91baef72338ec.tar.bz2
aports-b1274f164d3742fc5a47f4ab85a91baef72338ec.tar.xz
community/perl-[t-y]: modernize APKBUILD
Changes: - Move tests to check() - Remove return 1 - rename _builddir to builddir
Diffstat (limited to 'community/perl-text-roman')
-rw-r--r--community/perl-text-roman/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/community/perl-text-roman/APKBUILD b/community/perl-text-roman/APKBUILD
index cee9df66c9..1a292d8f9a 100644
--- a/community/perl-text-roman/APKBUILD
+++ b/community/perl-text-roman/APKBUILD
@@ -4,7 +4,7 @@
pkgname=perl-text-roman
_pkgreal=Text-Roman
pkgver=3.5
-pkgrel=0
+pkgrel=1
pkgdesc="Allows conversion between Roman and Arabic algarisms."
url="http://search.cpan.org/dist/Text-Roman/"
arch="noarch"
@@ -18,7 +18,7 @@ source="http://search.cpan.org/CPAN/authors/id/S/SY/SYP/$_pkgreal-$pkgver.tar.gz
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- default_prepare || return 1
+ default_prepare
cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
@@ -28,7 +28,12 @@ prepare() {
build() {
cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
@@ -37,6 +42,4 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="1f6b09c0cc1f4425b565ff787a39fd83 Text-Roman-3.5.tar.gz"
-sha256sums="cb4a08a3b151802ffb2fce3258a416542ab81db0f739ee474a9583ffb73e046a Text-Roman-3.5.tar.gz"
sha512sums="597ca054094f58c0983c66ce2b22dbc4d69861b02495663987e6b66dc0044a0d7e18e51ef817ed3c76832d283c01c6f9f51e68af7cb6b186b27553b5a877bc33 Text-Roman-3.5.tar.gz"