aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-text-template
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-07-29 08:47:38 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-08-16 20:37:16 +0000
commit558c93c4e14eee2d4aac407d8f72ebde6cfd7bb6 (patch)
tree4011c828b5eae424055240ce53d2da3eaf5573fb /community/perl-text-template
parentd994de25946f8207e3715c367bd52269ec08a19b (diff)
downloadaports-558c93c4e14eee2d4aac407d8f72ebde6cfd7bb6.tar.bz2
aports-558c93c4e14eee2d4aac407d8f72ebde6cfd7bb6.tar.xz
community/perl-text-template: move from main
It is required only by rt4 package and it is part of community.
Diffstat (limited to 'community/perl-text-template')
-rw-r--r--community/perl-text-template/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/perl-text-template/APKBUILD b/community/perl-text-template/APKBUILD
new file mode 100644
index 0000000000..172c12cd4e
--- /dev/null
+++ b/community/perl-text-template/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=perl-text-template
+pkgver=1.51
+pkgrel=0
+pkgdesc="Text::Template perl module"
+url="http://search.cpan.org/dist/Text-Template"
+arch="noarch"
+license="GPL-1.0-or-later Artistic-1.0-Perl"
+depends="perl"
+makedepends="perl-dev"
+checkdepends="perl-test-warnings"
+install=""
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/M/MS/MSCHOUT/Text-Template-$pkgver.tar.gz"
+
+builddir="$srcdir/Text-Template-$pkgver"
+build() {
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make && make test
+}
+
+check() {
+ make -C "$builddir" test
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="038a810746684b26cd6a763cfb8adff57a2ed8dc57e44b170b6ba6c8271d513289546294439cfe1c8b77f40153751596a023079ee79bfc6b59fa9393cfcc04f4 Text-Template-1.51.tar.gz"