aboutsummaryrefslogtreecommitdiffstats
path: root/community/perl-xml-libxml
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-05 12:12:49 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-11-05 12:12:52 +0000
commitd8c0e5b27afd0fbc7da791fa48905ea99b9ec4bb (patch)
tree01639323c91994f7a8407d2a0b10ac4e2442aaa7 /community/perl-xml-libxml
parent4e7d24c28f01bf6090327b6243c70f942bae0875 (diff)
downloadaports-d8c0e5b27afd0fbc7da791fa48905ea99b9ec4bb.tar.bz2
aports-d8c0e5b27afd0fbc7da791fa48905ea99b9ec4bb.tar.xz
community/perl-xml-libxml: enable tests again
with the upgrade to version 2.0132, all the tests seems to be working fine now
Diffstat (limited to 'community/perl-xml-libxml')
-rw-r--r--community/perl-xml-libxml/APKBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/community/perl-xml-libxml/APKBUILD b/community/perl-xml-libxml/APKBUILD
index 97594c9bb7..c08e8d2d4f 100644
--- a/community/perl-xml-libxml/APKBUILD
+++ b/community/perl-xml-libxml/APKBUILD
@@ -4,7 +4,7 @@
pkgname=perl-xml-libxml
_pkgreal=XML-LibXML
pkgver=2.0132
-pkgrel=0
+pkgrel=1
pkgdesc="Interface to Gnome libxml2 xml parsing and DOM library"
url="http://search.cpan.org/dist/XML-LibXML/"
arch="all"
@@ -16,23 +16,28 @@ makedepends="perl-dev $cpanmakedepends libxml2-dev"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/S/SH/SHLOMIF/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make #&& make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}