aboutsummaryrefslogtreecommitdiffstats
path: root/community/pgbouncer
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-11-01 10:21:24 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-11-07 16:46:13 +0000
commit60785abc20208c3ee6608c9b181e1e2ec8b3ccb5 (patch)
tree18dbfa5ab99c4f18612c0efb659e6718204d9e4f /community/pgbouncer
parent78399047516ffd12f75fc672f7f8081c89e94865 (diff)
downloadaports-60785abc20208c3ee6608c9b181e1e2ec8b3ccb5.tar.bz2
aports-60785abc20208c3ee6608c9b181e1e2ec8b3ccb5.tar.xz
community/pgbouncer: rebuild against openssl 1.1
Diffstat (limited to 'community/pgbouncer')
-rw-r--r--community/pgbouncer/APKBUILD8
-rw-r--r--community/pgbouncer/const_free.patch19
-rw-r--r--community/pgbouncer/libressl-2.5.patch13
3 files changed, 23 insertions, 17 deletions
diff --git a/community/pgbouncer/APKBUILD b/community/pgbouncer/APKBUILD
index 612ff6822f..029a741302 100644
--- a/community/pgbouncer/APKBUILD
+++ b/community/pgbouncer/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=pgbouncer
pkgver=1.9.0
-pkgrel=0
+pkgrel=1
pkgdesc="A lightweight connection pooler for PostgreSQL"
url="https://wiki.postgresql.org/wiki/PgBouncer"
arch="all"
@@ -10,14 +10,14 @@ license="BSD"
pkgusers="pgbouncer"
pkggroups="postgres"
install="$pkgname.pre-install"
-makedepends="c-ares-dev libevent-dev libressl-dev udns-dev"
+makedepends="c-ares-dev libevent-dev openssl-dev udns-dev"
subpackages="$pkgname-doc $pkgname-openrc"
source="https://pgbouncer.github.io/downloads/files/$pkgver/$pkgname-$pkgver.tar.gz
$pkgname.initd
$pkgname.confd
$pkgname.logrotate
pgbouncer-dirs.patch
- libressl-2.5.patch
+ const_free.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -53,4 +53,4 @@ a6dbfa477c2f0a405e4bf9ee0037165531802366565d0f192931ccd8a7cb3edf9e9b628655e41695
808621351b0f5973427fa22f63128432b00ac20fd25af437e8148dad9e55185775aba612b6ecdd58e4a6f2450b8c7838fcace288845b9b3cd0236bbe168aa574 pgbouncer.confd
83b869466b59c1b1d6e316a9368f725181128c1f5a7af230e3fa9c58ccda1bc097db182806c1c51a5121692791ec83d9eb0f5718fb3031f521bb537001153e2d pgbouncer.logrotate
fc80bef08d2f053564f4622c62dde1db9f19a34850a96dc4adb14b9766e5cecfa7fd65c49b70dd51a25e40cb4f5c47bec6dd3f92854620de532c0895b3e5ed80 pgbouncer-dirs.patch
-97caf142578f2f9d1500979ce88244554f316f999837707137dc4c3ec6ebc45bcef16678e61fdd1118bf4e26c7df733bd399f4a82b9b5a8e44c3497ab0922524 libressl-2.5.patch"
+5b5a1460ac22ce8b027d1a1d6069e826e7e1ca1fe33b99fbc40c4fb3615821530c0978b0311504db4da39af7f5413dd8c5c1e45a60af18a73f1c01527ad9bb13 const_free.patch"
diff --git a/community/pgbouncer/const_free.patch b/community/pgbouncer/const_free.patch
new file mode 100644
index 0000000000..a422130e50
--- /dev/null
+++ b/community/pgbouncer/const_free.patch
@@ -0,0 +1,19 @@
+diff --git a/lib/usual/base.h b/lib/usual/base.h
+index 99b23fe..f835e33 100644
+--- a/lib/usual/base.h
++++ b/lib/usual/base.h
+@@ -327,14 +327,6 @@ void log_fatal(const char *file, int line, const char *func, bool show_perror, v
+ #endif
+ #endif
+
+-/* Fix posix bug by accepting const pointer. */
+-static inline void _const_free(const void *p)
+-{
+- free((void *)p);
+-}
+-/** Compat: make free() accept const pointer */
+-#define free(x) _const_free(x)
+-
+ /** Zeroing malloc */
+ _MUSTCHECK
+ static inline void *zmalloc(size_t len)
diff --git a/community/pgbouncer/libressl-2.5.patch b/community/pgbouncer/libressl-2.5.patch
deleted file mode 100644
index 8aaae74dbc..0000000000
--- a/community/pgbouncer/libressl-2.5.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/lib/usual/tls/tls.c b/lib/usual/tls/tls.c
-index 9c6f6b9..a480fa4 100644
---- a/lib/usual/tls/tls.c
-+++ b/lib/usual/tls/tls.c
-@@ -287,7 +287,7 @@ tls_info_callback(const SSL *ssl, int where, int rc)
- {
- struct tls *ctx = SSL_get_app_data(ssl);
-
--#ifdef USE_LIBSSL_INTERNALS
-+#if defined(USE_LIBSSL_INTERNALS) && LIBRESSL_VERSION_NUMBER < 0x2050100fL
- if (!(ctx->state & TLS_HANDSHAKE_COMPLETE) && ssl->s3) {
- /* steal info about used DH key */
- if (ssl->s3->tmp.dh && !ctx->used_dh_bits) {