aboutsummaryrefslogtreecommitdiffstats
path: root/community/phodav
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2019-04-11 21:22:15 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-11 20:29:40 +0000
commitcce8ef4b00a4bc9fdad7a4097c1b39fe048ae583 (patch)
treedba95ff2b96e9f26d8902e250c89b0fdc878cee0 /community/phodav
parent96b616bb92d9c12bbf5558991a45fbe57c4f6f2f (diff)
downloadaports-cce8ef4b00a4bc9fdad7a4097c1b39fe048ae583.tar.bz2
aports-cce8ef4b00a4bc9fdad7a4097c1b39fe048ae583.tar.xz
community/phodav: upgrade to 2.3
Diffstat (limited to 'community/phodav')
-rw-r--r--community/phodav/APKBUILD58
-rw-r--r--community/phodav/meson_build-udev.patch30
-rw-r--r--community/phodav/spice-webdavd.initd5
3 files changed, 58 insertions, 35 deletions
diff --git a/community/phodav/APKBUILD b/community/phodav/APKBUILD
index b8d140dc37..49dc3d3b93 100644
--- a/community/phodav/APKBUILD
+++ b/community/phodav/APKBUILD
@@ -1,50 +1,45 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=phodav
-pkgver=2.2
+pkgver=2.3
pkgrel=0
pkgdesc="A WebDAV server using libsoup"
url="https://wiki.gnome.org/phodav"
arch="all"
license="LGPL-2.0-or-later"
-depends=""
-depends_dev=""
-makedepends="$depends_dev libsoup-dev avahi-dev intltool"
-install=""
-subpackages="$pkgname-dev $pkgname-doc $pkgname-lang chezdav
- spice-webdavd:spice"
+options="!check" # No test suite
+makedepends="avahi-dev gtk-doc intltool libsoup-dev meson eudev-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-openrc
+ chezdav spice-webdavd:spice"
source="https://download.gnome.org/sources/phodav/$pkgver/phodav-$pkgver.tar.xz
- spice-webdavd.initd"
-
-_builddir="$srcdir"/phodav-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+ spice-webdavd.initd
+ meson_build-udev.patch
+ "
+builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$_builddir"
- DATADIRNAME=share ./configure \
- --build=$CBUILD \
- --host=$CHOST \
+ cd "$builddir"
+
+ meson build/ \
--prefix=/usr \
+ --datadir=share \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
- --with-avahi \
- --with-udevdir=/lib/udev \
- || return 1
- make || return 1
+ -Davahi=enabled \
+ -Dudev=enabled
+
+ # print config options to log
+ meson configure build/
+
+ ninja -C build/
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+
+ DESTDIR="$pkgdir" ninja -C build install
+
rm -rf "$pkgdir"/usr/lib/systemd
install -Dm755 "$srcdir"/spice-webdavd.initd \
"$pkgdir"/etc/init.d/spice-webdavd
@@ -64,5 +59,6 @@ spice() {
}
-sha512sums="1d16716c1bda674a6695b651e9b1bcb4b7cfefd9b60291ed3f5691f4f6f45f68a970d99fc4820bed0484cf0a43c1bf32e4d208fcc239ac0c0b7a75bf779e8913 phodav-2.2.tar.xz
-9c38481ea8d59c4abee273080e7c48804c1453669804de008a98324c47e21253cbedf7b78e734afd12f4769fe3b451972f44d1dfd53012e2af02605a7fb2b916 spice-webdavd.initd"
+sha512sums="5f76ed0a4322707d117fc40a7bcab3a0bed7e53de52e0517e3ad79e3a6d93fc0200f6b54d8e001941d76ae22bd7f9ad158c0bee19354a316a18691057b65a002 phodav-2.3.tar.xz
+26db271c92760c38cf88bee6f8486e1c64aeaf81b19906783a3ea5e60054b2d5e7effdd26c59789ae3e964baa8bb498358724322b360bce229b45b6bee68f538 spice-webdavd.initd
+5ab7b8577ad78148a49d5218f839d4e82cce01167ca5d451b121f33c292ec5f6875e7d5d78b5f2969626e34b4225091a192f70c7916886651c39c60369cf2e7d meson_build-udev.patch"
diff --git a/community/phodav/meson_build-udev.patch b/community/phodav/meson_build-udev.patch
new file mode 100644
index 0000000000..40f0eae36d
--- /dev/null
+++ b/community/phodav/meson_build-udev.patch
@@ -0,0 +1,30 @@
+https://gitlab.gnome.org/GNOME/phodav/commit/3925b28f356feef6b67ef95eae6de378df44100d
+
+This patch can be deleted with next releases (2.3+)
+-----------------------
+--- a/meson.build
++++ b/meson.build
+@@ -53,7 +53,7 @@
+ )
+ endif
+
+-udev = dependency('udev', required : get_option('systemd'))
++udev = dependency('udev', required : get_option('udev'))
+ if udev.found()
+ install_data(
+ 'data/70-spice-webdavd.rules',
+
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -10,6 +10,10 @@
+ type : 'feature',
+ description : 'Install systemd units/configuration')
+
++option('udev',
++ type : 'feature',
++ description : 'Install udev rules')
++
+ option('build-id',
+ type : 'integer',
+ value : 0,
+
diff --git a/community/phodav/spice-webdavd.initd b/community/phodav/spice-webdavd.initd
index 9f83542f36..652ecd166b 100644
--- a/community/phodav/spice-webdavd.initd
+++ b/community/phodav/spice-webdavd.initd
@@ -1,7 +1,4 @@
-#!/sbin/runscript
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/phodav/files/spice-webdavd.initd,v 1.1 2014/06/13 12:05:09 dev-zero Exp $
+#!/sbin/openrc-run
description="Spice guest utility for file sharing via WebDAV"