aboutsummaryrefslogtreecommitdiffstats
path: root/community/phodav
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-07-17 08:35:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-17 08:44:05 +0000
commit9912f4aed6171339a6ff147585ad624aa838a4e2 (patch)
treea91f87e9c1790af658392c8be1ee4b09a3d9d5b4 /community/phodav
parent21f11f1c19db2e35e69b82c24d88c09d5ade888e (diff)
downloadaports-9912f4aed6171339a6ff147585ad624aa838a4e2.tar.bz2
aports-9912f4aed6171339a6ff147585ad624aa838a4e2.tar.xz
main/phodav: move to community
Diffstat (limited to 'community/phodav')
-rw-r--r--community/phodav/APKBUILD68
-rw-r--r--community/phodav/spice-webdavd.initd17
2 files changed, 85 insertions, 0 deletions
diff --git a/community/phodav/APKBUILD b/community/phodav/APKBUILD
new file mode 100644
index 0000000000..96f575883c
--- /dev/null
+++ b/community/phodav/APKBUILD
@@ -0,0 +1,68 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=phodav
+pkgver=2.2
+pkgrel=0
+pkgdesc="A WebDAV server using libsoup"
+url="https://wiki.gnome.org/phodav"
+arch="all"
+license="LGPL-2.0-or-later"
+depends=""
+depends_dev=""
+makedepends="$depends_dev libsoup-dev avahi-dev intltool"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang chezdav
+ spice-webdavd:spice"
+source="http://download.gnome.org/sources/phodav/$pkgver/phodav-$pkgver.tar.xz
+ spice-webdavd.initd"
+
+_builddir="$srcdir"/phodav-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ DATADIRNAME=share ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --with-avahi \
+ --with-udevdir=/lib/udev \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -rf "$pkgdir"/usr/lib/systemd
+ install -Dm755 "$srcdir"/spice-webdavd.initd \
+ "$pkgdir"/etc/init.d/spice-webdavd
+}
+
+chezdav() {
+ pkgdesc="A simple WebDAV server program"
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+}
+
+spice() {
+ pkgdesc="Spice daemon for the DAV channel"
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/sbin "$subpkgdir"/usr/
+ mv "$pkgdir"/lib "$pkgdir"/etc "$subpkgdir"/
+}
+
+
+sha512sums="1d16716c1bda674a6695b651e9b1bcb4b7cfefd9b60291ed3f5691f4f6f45f68a970d99fc4820bed0484cf0a43c1bf32e4d208fcc239ac0c0b7a75bf779e8913 phodav-2.2.tar.xz
+9c38481ea8d59c4abee273080e7c48804c1453669804de008a98324c47e21253cbedf7b78e734afd12f4769fe3b451972f44d1dfd53012e2af02605a7fb2b916 spice-webdavd.initd"
diff --git a/community/phodav/spice-webdavd.initd b/community/phodav/spice-webdavd.initd
new file mode 100644
index 0000000000..9f83542f36
--- /dev/null
+++ b/community/phodav/spice-webdavd.initd
@@ -0,0 +1,17 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/phodav/files/spice-webdavd.initd,v 1.1 2014/06/13 12:05:09 dev-zero Exp $
+
+description="Spice guest utility for file sharing via WebDAV"
+
+command="/usr/sbin/spice-webdavd"
+command_args="--port 9843"
+
+pidfile="/run/${SVCNAME}.pid"
+command_background="yes"
+
+depend() {
+ need dbus
+ use avahi
+}