aboutsummaryrefslogtreecommitdiffstats
path: root/community/phonon-backend-gstreamer
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-05-28 22:00:28 +0200
committerFrancesco Colista <fcolista@alpinelinux.org>2019-05-29 12:26:57 +0000
commit5d1d559692c085db8ef96eb14a2a3c8f8c6469c8 (patch)
tree64ccec444688017d3aa447dcf481bf88444c3875 /community/phonon-backend-gstreamer
parentdcd9d99c3e45ab8b070ccb76b32354cc60d7c154 (diff)
downloadaports-5d1d559692c085db8ef96eb14a2a3c8f8c6469c8.tar.bz2
aports-5d1d559692c085db8ef96eb14a2a3c8f8c6469c8.tar.xz
community/phonon-backend-gstreamer: move to Qt5 and modernize
Diffstat (limited to 'community/phonon-backend-gstreamer')
-rw-r--r--community/phonon-backend-gstreamer/APKBUILD21
1 files changed, 8 insertions, 13 deletions
diff --git a/community/phonon-backend-gstreamer/APKBUILD b/community/phonon-backend-gstreamer/APKBUILD
index c24d3ba335..fa366ea5af 100644
--- a/community/phonon-backend-gstreamer/APKBUILD
+++ b/community/phonon-backend-gstreamer/APKBUILD
@@ -2,32 +2,27 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=phonon-backend-gstreamer
pkgver=4.9.0
-pkgrel=2
-pkgdesc="phonon gstreamer backend for Qt4"
+pkgrel=3
+pkgdesc="Phonon gstreamer backend for Qt5"
url="https://phonon.kde.org/"
arch="all"
license="LGPL-2.1-only OR LGPL-3.0-only"
-depends_dev="gstreamer-dev gst-plugins-base-dev phonon-dev"
-makedepends="$depends_dev cmake automoc4"
+makedepends="extra-cmake-modules qt5-qtx11extras-dev gstreamer-dev gst-plugins-base-dev phonon-dev"
source="https://download.kde.org/stable/phonon/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz"
-
+options="!check" # No tests available
builddir="$srcdir"/phonon-gstreamer-$pkgver
build() {
- mkdir -p "$builddir"/build
- cd "$builddir"/build
- cmake "$builddir" \
- -DCMAKE_BUILD_TYPE=Release \
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_SKIP_RPATH=ON \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_CXX_FLAGS="$CXXFLAGS $(pkgconf --cflags gstreamer-1.0)"
+ -DPHONON_BUILD_PHONON4QT5=ON
make
}
package() {
- cd "$builddir"/build
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" make install
}
sha512sums="9c13d37c6c7070c2bd8fcc562f743ac2f55289bc7cc82147ef0ae990e5d380d541cc1d9ce61e6ad1549ed1935d41faafaeeb0cd5463e4c656ea8fee636ff4dfe phonon-backend-gstreamer-4.9.0.tar.xz"