aboutsummaryrefslogtreecommitdiffstats
path: root/community/php5-apcu/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-03-28 13:54:43 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-03-28 18:38:20 +0200
commit4272e802a1be191657becb739e6a248c1d0411a7 (patch)
treea07a25b7c99d7da326957a88173ba49583cf6b2a /community/php5-apcu/APKBUILD
parent3e272105092cd9804a5a022a188db929ebf440da (diff)
downloadaports-4272e802a1be191657becb739e6a248c1d0411a7.tar.bz2
aports-4272e802a1be191657becb739e6a248c1d0411a7.tar.xz
community/*: move php5 and dependent pkgs from main
There two main reasons for this change: * Active support of PHP 5.x ended on January 2017, security support will end on December 2018. Packages in the main repository should be supported for at least 2 years, this means until first quarter of 2019 for the upcoming v3.6. * php7 and its extensions are currently in the community repository, so we can't use single abuild for both php5-* and php7-* packages (as we do for Python and Lua packages). This change was suggested by @vakartel, approved by @ncopa, @kaniini, and @jirutka.
Diffstat (limited to 'community/php5-apcu/APKBUILD')
-rw-r--r--community/php5-apcu/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/community/php5-apcu/APKBUILD b/community/php5-apcu/APKBUILD
new file mode 100644
index 0000000000..4059d7cc49
--- /dev/null
+++ b/community/php5-apcu/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
+# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
+_php=php5
+pkgname=${_php}-apcu
+_pkgreal=apcu
+# release 5 is php7+
+pkgver=4.0.11
+_pkgver=${pkgver/_rc/RC}
+pkgrel=1
+pkgdesc="PHP extension APC User Cache"
+url="http://pecl.php.net/package/$_pkgreal"
+arch="all"
+license="PHP"
+depends=
+pecldepends="${_php}-dev autoconf"
+makedepends="$pecldepends pcre-dev"
+install=""
+subpackages=""
+source="http://pecl.php.net/get/$_pkgreal-$_pkgver.tgz"
+
+_builddir="$srcdir"/$_pkgreal-$_pkgver
+
+build() {
+ cd "$_builddir"
+ phpize || return 1
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make INSTALL_ROOT="$pkgdir"/ install || return 1
+ install -d "$pkgdir"/etc/$_php/conf.d || return 1
+ echo "extension=$_pkgreal.so" > "$pkgdir"/etc/$_php/conf.d/$_pkgreal.ini
+}
+
+md5sums="13c0c0dd676e5a7905d54fa985d0ee62 apcu-4.0.11.tgz"
+sha256sums="454f302ec13a6047ca4c39e081217ce5a61bbea815aec9c1091fb849e70b4d00 apcu-4.0.11.tgz"
+sha512sums="e3b97066240e33850419e96f0fd9df0e66ee3b0fa238c418e07ac639d07439e9edfa1696e56a620e33f1ffc0993c57bde585b0c170b22995e7d5c0ae550b7899 apcu-4.0.11.tgz"