aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7-pear-auth_sasl2/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-26 01:25:27 -0300
committerFrancesco Colista <fcolista@alpinelinux.org>2019-05-27 15:04:28 +0000
commit30b63557016b90f49eadd49171d07e5f184a1392 (patch)
treea2a91fc1558dfa729e229168bfcd24ca900d48cd /community/php7-pear-auth_sasl2/APKBUILD
parent0067f76364fba1e5cd844a0d85b47c50f34dff3c (diff)
downloadaports-30b63557016b90f49eadd49171d07e5f184a1392.tar.bz2
aports-30b63557016b90f49eadd49171d07e5f184a1392.tar.xz
community/php7-pear-auth_sasl2: modernize, fix license.
Diffstat (limited to 'community/php7-pear-auth_sasl2/APKBUILD')
-rw-r--r--community/php7-pear-auth_sasl2/APKBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/community/php7-pear-auth_sasl2/APKBUILD b/community/php7-pear-auth_sasl2/APKBUILD
index 86c98334e7..c826059c0b 100644
--- a/community/php7-pear-auth_sasl2/APKBUILD
+++ b/community/php7-pear-auth_sasl2/APKBUILD
@@ -3,26 +3,20 @@ _php=php7
pkgname=${_php}-pear-auth_sasl2
_realname=Auth_SASL2
pkgver=0.2.0
-pkgrel=0
+pkgrel=1
pkgdesc="Abstraction of various SASL mechanism responses"
url="http://pear.php.net/package/Auth_SASL2"
arch="noarch"
-license="BSD"
+license="BSD-3-Clause"
depends="${_php}-pear"
-makedepends="$depends_dev ${_php}-pear"
-options="!check"
+options="!check" # No testsuite
source="$pkgname-$pkgver.tgz::http://download.pear.php.net/package/$_realname-$pkgver.tgz"
builddir="$srcdir"/$_realname-$pkgver
-build() {
- return 0
-}
-
package() {
_phpdir="usr/lib/$_php"
- cd "$builddir"
install -d "$pkgdir"/$_phpdir/PEAR && \
- cp -R Auth "$pkgdir"/$_phpdir/PEAR || return 1
+ cp -R Auth "$pkgdir"/$_phpdir/PEAR
}
sha512sums="ea4bed18d241e9e43e3d3b1edc8aec713276a19ed6fa2b2adc44cfe74b51895b719e4fbbf83836b26abb8bfa7f0600891b2c4511ddcc3f6d815e986a61277402 php7-pear-auth_sasl2-0.2.0.tgz"