aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7-pecl-mailparse
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-10-20 22:25:17 +0300
committerAndy Postnikov <apostnikov@gmail.com>2018-10-21 00:28:59 +0300
commit3c6cf472f2791fc533ed94dc6c88a5f6497220ac (patch)
tree03383955ee149af85b4345226bf598c0e147019d /community/php7-pecl-mailparse
parentf632bf02bdda1b0ed0bc2a1d7c146f7b6c9f0c46 (diff)
downloadaports-3c6cf472f2791fc533ed94dc6c88a5f6497220ac.tar.bz2
aports-3c6cf472f2791fc533ed94dc6c88a5f6497220ac.tar.xz
community/php7-pecl-mailparse: renamed from php7-mailparse
Diffstat (limited to 'community/php7-pecl-mailparse')
-rw-r--r--community/php7-pecl-mailparse/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/community/php7-pecl-mailparse/APKBUILD b/community/php7-pecl-mailparse/APKBUILD
new file mode 100644
index 0000000000..a30ee4ff34
--- /dev/null
+++ b/community/php7-pecl-mailparse/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
+# Maintainer: Fabio Ribeiro <fabiorphp@gmail.com>
+pkgname=php7-pecl-mailparse
+_pkgreal=mailparse
+pkgver=3.0.2
+pkgrel=4
+pkgdesc="PHP extension for parsing and working with email messages - PECL"
+url="https://pecl.php.net/package/mailparse"
+arch="all"
+license="PHP"
+depends="php7-common php7-mbstring"
+makedepends="php7-dev autoconf re2c"
+source="$pkgname-$pkgver.tgz::https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+provides="php7-mailparse=$pkgver-r$pkgrel" # for backward compatibility
+replaces="php7-mailparse" # for backward compatibility
+
+build() {
+ cd "$builddir"
+
+ phpize7
+ ./configure --prefix=/usr --with-php-config=php-config7
+ make
+}
+
+check() {
+ cd "$builddir"
+ # Tests require mbstring extension which is not bundled
+ sed -i 's#PHP_TEST_SHARED_EXTENSIONS = `#PHP_TEST_SHARED_EXTENSIONS = -d extension=/usr/lib/php7/modules/mbstring.so `#' Makefile
+ # Current upstream package has no test data for following tests
+ rm -f tests/011.phpt tests/bug001.phpt tests/parse_test_messages.phpt
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
+}
+
+package() {
+ local confdir="$pkgdir/etc/php7/conf.d"
+ cd "$builddir"
+
+ make INSTALL_ROOT="$pkgdir" install
+
+ mkdir -p "$confdir"
+ echo "extension=$_pkgreal.so" > "$confdir"/60_$_pkgreal.ini
+}
+
+sha512sums="be04e15cf3577542447186d7ead4e31159c171c99de0a255d4ee2f6f760b80ecb44be056bd9089180601f622b9a71f4331f194e1adaa702d1d964009682896f6 php7-pecl-mailparse-3.0.2.tgz"