aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7-pecl-oauth
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-10-21 01:12:46 +0300
committerAndy Postnikov <apostnikov@gmail.com>2018-10-21 01:16:15 +0300
commitcab22533c14a5d8d9943401348102343d34df48d (patch)
tree523c9a8c3f4463ee19f6e1aa751847b636fdebcd /community/php7-pecl-oauth
parent815953befd17c444d36abf467d47d7b8df291523 (diff)
downloadaports-cab22533c14a5d8d9943401348102343d34df48d.tar.bz2
aports-cab22533c14a5d8d9943401348102343d34df48d.tar.xz
community/php7-pecl-oauth: renamed from php7-oauth, modernize
Diffstat (limited to 'community/php7-pecl-oauth')
-rw-r--r--community/php7-pecl-oauth/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/php7-pecl-oauth/APKBUILD b/community/php7-pecl-oauth/APKBUILD
new file mode 100644
index 0000000000..6df4992158
--- /dev/null
+++ b/community/php7-pecl-oauth/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
+# Maintainer: Fabio Ribeiro <fabiorphp@gmail.com>
+pkgname=php7-pecl-oauth
+_pkgreal=oauth
+pkgver=2.0.3
+pkgrel=1
+pkgdesc="OAuth is an authorization protocol built on top of HTTP."
+url="https://pecl.php.net/package/oauth"
+arch="all"
+license="PHP"
+depends="php7-common"
+makedepends="php7-dev autoconf pcre-dev curl-dev"
+source="https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
+builddir="$srcdir"/$_pkgreal-$pkgver
+provides="php7-oauth=$pkgver-r$pkgrel" # for backward compatibility
+replaces="php7-oauth" # for backward compatibility
+
+build() {
+ cd "$builddir"
+ phpize7
+ ./configure --prefix=/usr --with-php-config=php-config7
+ make
+}
+
+check() {
+ cd "$builddir"
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
+}
+
+package() {
+ cd "$builddir"
+ make INSTALL_ROOT="$pkgdir"/ install
+ install -d "$pkgdir"/etc/php7/conf.d
+ echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/60_$_pkgreal.ini
+}
+
+sha512sums="3e0ce5ce01533bfd304c0c34465cc184fbd0af1a25f5192860e6394c86dc948688cc8d4b419b48676481cef3a685ba70ac612a8c516da26d0dfe9efdef7e98d9 oauth-2.0.3.tgz"