aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7-pecl-protobuf/APKBUILD
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2019-05-23 15:17:14 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-24 10:51:04 +0000
commit5bb0fb897d38696c91893ecf6b025664501dc663 (patch)
treef867f5e727108e6fb2d45f2c10303c88cb2eb2b3 /community/php7-pecl-protobuf/APKBUILD
parentc36a1cd478b9d4a96e779df2565ec2b1a0cf617a (diff)
downloadaports-5bb0fb897d38696c91893ecf6b025664501dc663.tar.bz2
aports-5bb0fb897d38696c91893ecf6b025664501dc663.tar.xz
community/php7-pecl-protobuf: move from testing
Diffstat (limited to 'community/php7-pecl-protobuf/APKBUILD')
-rw-r--r--community/php7-pecl-protobuf/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/php7-pecl-protobuf/APKBUILD b/community/php7-pecl-protobuf/APKBUILD
new file mode 100644
index 0000000000..18603212bd
--- /dev/null
+++ b/community/php7-pecl-protobuf/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: TBK <alpine@jjtc.eu>
+# Maintainer: TBK <alpine@jjtc.eu>
+pkgname=php7-pecl-protobuf
+_pkgreal=protobuf
+pkgver=3.7.1
+pkgrel=0
+pkgdesc="PHP7 extension: Google's language-neutral, platform-neutral, extensible mechanism for serializing structured data."
+url="https://pecl.php.net/package/protobuf"
+arch="all"
+license="BSD-3-Clause"
+depends="php7-common"
+makedepends="php7-dev autoconf libtool"
+source="https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+provides="php7-protobuf=$pkgver-r$pkgrel" # for backward compatibility
+replaces="php7-protobuf" # for backward compatibility
+
+build() {
+ phpize7
+ ./configure --prefix=/usr --with-php-config=php-config7
+ make
+}
+
+check() {
+ # Test suite is not a part of pecl release.
+ php7 -d extension="$builddir"/modules/$_pkgreal.so --ri $_pkgreal
+}
+
+package() {
+ make INSTALL_ROOT="$pkgdir" install
+ install -d "$pkgdir"/etc/php7/conf.d
+ echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/$_pkgreal.ini
+}
+
+sha512sums="bf35c4165e0440b26f32c73befa3b2827a07a33ab37d9d5c51f0f66836f6115c05a6163e90bd8d528196d5383bee51c9ecaf96d70f4ebd53fe93db40566350e3 protobuf-3.7.1.tgz"