aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7-pecl-vips
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2020-04-22 19:55:50 +0300
committerAndy Postnikov <apostnikov@gmail.com>2020-04-22 20:01:07 +0300
commit9fe12e8611d99aa4d2b8ce1033be567348fb1e6e (patch)
tree2a85e2d7e3a2afcb41d660bea412f20b5cafc65f /community/php7-pecl-vips
parent4ba5a5fe5280881cee0d7ba9c8db747dc9a820a4 (diff)
downloadaports-9fe12e8611d99aa4d2b8ce1033be567348fb1e6e.tar.bz2
aports-9fe12e8611d99aa4d2b8ce1033be567348fb1e6e.tar.xz
community/php7-pecl-vips: run all tests and clean-up
Diffstat (limited to 'community/php7-pecl-vips')
-rw-r--r--community/php7-pecl-vips/APKBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/community/php7-pecl-vips/APKBUILD b/community/php7-pecl-vips/APKBUILD
index b4a72c460e..b0ac2e5c45 100644
--- a/community/php7-pecl-vips/APKBUILD
+++ b/community/php7-pecl-vips/APKBUILD
@@ -3,7 +3,7 @@
pkgname=php7-pecl-vips
_pkgname=vips
pkgver=1.0.10
-pkgrel=0
+pkgrel=1
pkgdesc="PHP extension for interfacing with vips - PECL"
url="https://pecl.php.net/package/vips"
arch="all !s390x !ppc64le" # Limited by vips aport
@@ -14,21 +14,20 @@ source="$pkgname-$pkgver.tgz::https://pecl.php.net/get/$_pkgname-$pkgver.tgz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- phpize7
- ./configure --prefix=/usr --with-php-config=php-config7
- make
+ phpize7
+ ./configure --prefix=/usr --with-php-config=php-config7
+ make
}
check() {
- rm -f tests/029.phpt # TODO remove after 8.8.4 release https://github.com/libvips/php-vips-ext/issues/33
- make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 SKIP_ONLINE_TESTS=1 test
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 SKIP_ONLINE_TESTS=1 test
}
package() {
- make INSTALL_ROOT="$pkgdir" install
+ make INSTALL_ROOT="$pkgdir" install
- install -d "$pkgdir"/etc/php7/conf.d
- echo "extension=$_pkgname.so" > "$pkgdir"/etc/php7/conf.d/$_pkgname.ini
+ install -d "$pkgdir"/etc/php7/conf.d
+ echo "extension=$_pkgname.so" > "$pkgdir"/etc/php7/conf.d/$_pkgname.ini
}
sha512sums="459f0e426d738128ad3cf1b45d8eeeec17f9919f508973407a76f42392ab2420023d46a9c40e097ceacbce22eb5c4697e4529fe196bc77237a266d8860423ba9 php7-pecl-vips-1.0.10.tgz"