aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7-pecl-xdebug/APKBUILD
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-12-06 17:42:10 +0200
committerAndy Postnikov <apostnikov@gmail.com>2018-12-07 01:24:12 +0200
commit79c40da64873d5c69cce050aace96de6211a9500 (patch)
tree450519339b4ddf4aa7d47f7689998437b0794d6d /community/php7-pecl-xdebug/APKBUILD
parentad5853afa1d866ddf5863affa38bf308a3df11f5 (diff)
downloadaports-79c40da64873d5c69cce050aace96de6211a9500.tar.bz2
aports-79c40da64873d5c69cce050aace96de6211a9500.tar.xz
community/php7-pecl-xdebug: add check() and scripts
Diffstat (limited to 'community/php7-pecl-xdebug/APKBUILD')
-rw-r--r--community/php7-pecl-xdebug/APKBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/community/php7-pecl-xdebug/APKBUILD b/community/php7-pecl-xdebug/APKBUILD
index 55a0679f6d..9f06855dd5 100644
--- a/community/php7-pecl-xdebug/APKBUILD
+++ b/community/php7-pecl-xdebug/APKBUILD
@@ -5,7 +5,7 @@
pkgname=php7-pecl-xdebug
_pkgname=xdebug
pkgver=2.6.1
-pkgrel=1
+pkgrel=2
pkgdesc="PHP extension that provides functions for function traces and profiling - PECL"
url="https://pecl.php.net/package/xdebug"
arch="all"
@@ -13,7 +13,6 @@ license="PHP"
depends="php7-common"
makedepends="php7-dev autoconf re2c"
source="$pkgname-$pkgver.tgz::https://pecl.php.net/get/$_pkgname-$pkgver.tgz"
-options="!check" # upstream does not provide tests yet
builddir="$srcdir/$_pkgname-$pkgver"
provides="php7-xdebug=$pkgver-r$pkgrel" # for backward compatibility
replaces="php7-xdebug" # for backward compatibility
@@ -26,11 +25,17 @@ build() {
make
}
+check() {
+ # PECL package has no test suite.
+ php7 -z "$builddir"/modules/xdebug.so -r "in_array('Xdebug', get_loaded_extensions(true)) ? exit(0) : exit(1);"
+}
+
package() {
local confdir="$pkgdir/etc/php7/conf.d"
cd "$builddir"
make INSTALL_ROOT="$pkgdir" install
+ install -D -m644 contrib/tracefile-analyser.php "$pkgdir"/usr/share/php7/xdebug/tracefile-analyser.php
mkdir -p "$confdir"
cat > "$confdir"/$_pkgname.ini <<-EOF