aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7-pecl-xhprof
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2019-12-10 18:50:31 +0200
committerAndy Postnikov <apostnikov@gmail.com>2019-12-11 14:37:20 +0200
commit692713c06d53fa7386cdf2ec839c8967bec9f243 (patch)
treef6e4a24d2089a8f7408d6c5d5d803058830e5093 /community/php7-pecl-xhprof
parentbe27a8efb91be98b6885c63556df7eb3f81e4c26 (diff)
downloadaports-692713c06d53fa7386cdf2ec839c8967bec9f243.tar.bz2
aports-692713c06d53fa7386cdf2ec839c8967bec9f243.tar.xz
community/php7-pecl-xhprof: moved from testing
Diffstat (limited to 'community/php7-pecl-xhprof')
-rw-r--r--community/php7-pecl-xhprof/APKBUILD58
1 files changed, 58 insertions, 0 deletions
diff --git a/community/php7-pecl-xhprof/APKBUILD b/community/php7-pecl-xhprof/APKBUILD
new file mode 100644
index 0000000000..c1a895bbfb
--- /dev/null
+++ b/community/php7-pecl-xhprof/APKBUILD
@@ -0,0 +1,58 @@
+# Contributor: Andy Postnikov <apostnikov@gmail.com>
+# Maintainer: Andy Postnikov <apostnikov@gmail.com>
+
+pkgname=php7-pecl-xhprof
+_pkgreal=xhprof
+pkgver=2.1.3
+pkgrel=1
+pkgdesc="A Hierarchical Profiler for PHP"
+url="https://pecl.php.net/package/xhprof"
+arch="all"
+license="Apache-2.0"
+depends="php7-ctype"
+makedepends="php7-dev re2c"
+subpackages="$pkgname-assets::noarch"
+source="$pkgname-$pkgver.tar.gz::https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+provides="php7-xhprof=$pkgver-r$pkgrel" # for backward compatibility
+replaces="php7-xhprof" # for backward compatibility
+
+build() {
+ cd "$builddir"/extension
+ phpize7
+ ./configure --with-php-config=php-config7
+ make
+}
+
+check() {
+ cd "$builddir"/extension
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
+}
+
+package() {
+ cd "$builddir"/extension
+ make INSTALL_ROOT="$pkgdir"/ install
+ local confdir="$pkgdir/etc/php7/conf.d"
+ install -d "$confdir"
+ cat > "$confdir"/$_pkgreal.ini <<-EOF
+ extension=$_pkgreal.so
+ xhprof.output_dir=/tmp
+ EOF
+ local installdir="$pkgdir"/usr/share/php7/xhprof
+ install -d "$installdir"
+ cp -R "$builddir"/xhprof_lib "$installdir"
+}
+
+assets() {
+ pkgdesc="A Hierarchical Profiler for PHP (UI assets)"
+ depends="$pkgname graphviz ghostscript-fonts"
+ provides="php7-xhprof-assets=$pkgver-r$pkgrel" # for backward compatibility
+ replaces="php7-xhprof-assets" # for backward compatibility
+
+ local installdir="$subpkgdir"/usr/share/php7/xhprof
+ install -d "$installdir"
+ cp -R "$builddir"/xhprof_html "$installdir"
+ cp -R "$builddir"/examples "$installdir"
+}
+
+sha512sums="c9a74fe48882afb10b352430bd1849ac35bb1fe9fd7d5918c57628c48a88e0919906fdd36b531ef0d5e6cd5424d6b4b8c1742c134e2ef71bb09ac5477bc17813 php7-pecl-xhprof-2.1.3.tar.gz"