aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7-pecl-zmq
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2019-04-12 13:51:49 +0300
committerAndy Postnikov <apostnikov@gmail.com>2019-04-12 14:47:49 +0300
commitf5c37421126bd55d85d5b2354b73b480c97ba9a8 (patch)
treeff66643754f706dd9f2b2ca8ad79bebae477c09b /community/php7-pecl-zmq
parentedc5b3f3c139599639feb16d003167883b7f2764 (diff)
downloadaports-f5c37421126bd55d85d5b2354b73b480c97ba9a8.tar.bz2
aports-f5c37421126bd55d85d5b2354b73b480c97ba9a8.tar.xz
community/php7-pecl-zmq: fix check()
Diffstat (limited to 'community/php7-pecl-zmq')
-rw-r--r--community/php7-pecl-zmq/APKBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/community/php7-pecl-zmq/APKBUILD b/community/php7-pecl-zmq/APKBUILD
index 09e5094ee7..909b7ff5e9 100644
--- a/community/php7-pecl-zmq/APKBUILD
+++ b/community/php7-pecl-zmq/APKBUILD
@@ -3,7 +3,7 @@
pkgname=php7-pecl-zmq
_pkgreal=zmq
pkgver=1.1.3
-pkgrel=4
+pkgrel=5
pkgdesc="PHP extension for ZeroMQ - PECL"
url="https://pecl.php.net/package/zmq"
arch="all"
@@ -11,7 +11,7 @@ license="PHP"
depends="php7-common"
makedepends="php7-dev autoconf zeromq-dev"
source="$pkgname-$pkgver.tgz::https://pecl.php.net/get/$_pkgreal-$pkgver.tgz
-fix-php-7.3-compile.patch"
+ fix-php-7.3-compile.patch"
builddir="$srcdir/$_pkgreal-$pkgver"
provides="php7-zmq=$pkgver-r$pkgrel" # for backward compatibility
replaces="php7-zmq" # for backward compatibility
@@ -27,8 +27,7 @@ build() {
check() {
cd "$builddir"
- # XXX: 007-addremovepoll.phpt fails, ignore it for now.
- make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test || true
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
}
package() {