aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7-redis
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-05-01 23:52:07 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-05-02 01:53:19 +0200
commitdabc633114fce3e03e6e0fd6f5ddb30317c57639 (patch)
tree34c9f819634f6bfb67c0eb0d634ac0067a9943b2 /community/php7-redis
parentbe7b53e094467e6cf0fd12042e72c5c4623aa86b (diff)
downloadaports-dabc633114fce3e03e6e0fd6f5ddb30317c57639.tar.bz2
aports-dabc633114fce3e03e6e0fd6f5ddb30317c57639.tar.xz
community/php7-redis: move from testing
Diffstat (limited to 'community/php7-redis')
-rw-r--r--community/php7-redis/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/php7-redis/APKBUILD b/community/php7-redis/APKBUILD
new file mode 100644
index 0000000000..cd8609b745
--- /dev/null
+++ b/community/php7-redis/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
+# Maintainer: Fabio Ribeiro <fabiorphp@gmail.com>
+pkgname=php7-redis
+_pkgreal=redis
+pkgver=3.1.2
+pkgrel=1
+_phpver=${pkgname#php}
+_phpver=${_phpver%%-*}
+pkgdesc="PHP$_phpver extension for interfacing with Redis"
+url="https://pecl.php.net/package/redis"
+arch="all"
+license="PHP"
+depends="php$_phpver-common php$_phpver-session"
+makedepends="php$_phpver-dev autoconf"
+source="$pkgname-$pkgver.tgz::http://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
+options="!check"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ cd "$builddir"
+
+ phpize$_phpver
+ ./configure --prefix=/usr --with-php-config=php-config$_phpver
+ make
+}
+
+package() {
+ local confdir="$pkgdir/etc/php$_phpver/conf.d"
+ cd "$builddir"
+
+ make INSTALL_ROOT="$pkgdir" install
+
+ mkdir -p "$confdir"
+ echo "extension=$_pkgreal.so" > "$confdir"/20_$_pkgreal.ini
+}
+
+sha512sums="14b6321072f8ab41b8293b40ea8e1e2bdac1bb694c4566467ea4e6ced37c8fc41bf5712bd27cebf509f25fda0492765cd2c8d2fe61395bcb0b0d9cbbceebe684 php7-redis-3.1.2.tgz"