aboutsummaryrefslogtreecommitdiffstats
path: root/community/php7
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-30 14:28:05 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-05-02 01:04:52 +0200
commit1cc6d4f5770581d2b6491cac5d396019fd0c8b5e (patch)
treeaff334a99f6bd257fc05a173d47d2ede0692eb1a /community/php7
parent18e5293f6da32096545b39c8c997302b26e02593 (diff)
downloadaports-1cc6d4f5770581d2b6491cac5d396019fd0c8b5e.tar.bz2
aports-1cc6d4f5770581d2b6491cac5d396019fd0c8b5e.tar.xz
community/php7: fix and unify configuration flags
* Add /usr where path is expected to use system-provided library instead of bundled and for *-dir options. * libxml cannot be build as shared. * Remove --with-libexpat-dir, it's deprecated. * Remove --enable-mbregex, it's enabled by default.
Diffstat (limited to 'community/php7')
-rw-r--r--community/php7/APKBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/community/php7/APKBUILD b/community/php7/APKBUILD
index 4d2375899d..e44b2f139a 100644
--- a/community/php7/APKBUILD
+++ b/community/php7/APKBUILD
@@ -22,7 +22,7 @@ depends_xmlreader="$pkgname-dom"
depends_xmlrpc="$pkgname-xml"
depends_xsl="$pkgname-dom"
makedepends="autoconf bison re2c apache2-dev libxml2-dev libxslt-dev libzip-dev bzip2-dev zlib-dev
- aspell-dev enchant-dev expat-dev pcre-dev curl-dev gmp-dev icu-dev imap-dev
+ aspell-dev enchant-dev pcre-dev curl-dev gmp-dev icu-dev imap-dev
libical-dev libressl-dev openldap-dev net-snmp-dev db-dev krb5-dev gdbm-dev sqlite-dev
freetds-dev postgresql-dev unixodbc-dev freetype-dev tidyhtml-dev libxpm-dev
libpng-dev libwebp-dev libjpeg-turbo-dev libmcrypt-dev recode-dev libedit-dev gettext-dev
@@ -77,6 +77,9 @@ prepare() {
# Notes:
# * gd-jis-conv breaks any non-latin font rendering (vakartel).
+# * libxml cannot be build as shared.
+# * Doesn't work with system-provided onigurama, some tests fail (invalid code
+# point); probably because bundled onigurama is version 5.x, but we have 6.x.
_build() {
[ "$CARCH" = "s390x" ] && _disable_pcre_jit="--without-pcre-jit"
@@ -96,9 +99,9 @@ _build() {
--with-config-file-scan-dir=$_extension_confd \
--disable-short-tags \
--with-openssl=shared --with-kerberos --with-system-ciphers \
- --with-pcre-regex=/usr --with-pcre-dir \
+ --with-pcre-regex=/usr --with-pcre-dir=/usr \
$_disable_pcre_jit \
- --with-zlib=shared --with-zlib-dir \
+ --with-zlib=shared --with-zlib-dir=/usr \
--enable-bcmath=shared \
--with-bz2=shared \
--enable-calendar=shared \
@@ -110,24 +113,24 @@ _build() {
--enable-exif=shared \
--enable-fileinfo=shared \
--enable-ftp=shared \
- --with-gd=shared --with-webp-dir=shared --with-jpeg-dir=shared --with-png-dir=shared --with-xpm-dir=shared \
- --with-freetype-dir=shared --enable-gd-native-ttf --disable-gd-jis-conv \
+ --with-gd=shared --with-webp-dir=/usr --with-jpeg-dir=/usr --with-png-dir=/usr --with-xpm-dir=/usr \
+ --with-freetype-dir=/usr --enable-gd-native-ttf --disable-gd-jis-conv \
--with-gettext=shared \
--with-gmp=shared \
--with-iconv=shared \
--with-imap=shared --with-imap-ssl \
--enable-intl=shared --with-icu-dir=/usr \
--enable-json=shared \
- --enable-libxml=shared --with-libxml-dir=shared --with-libexpat-dir=shared \
+ --enable-libxml --with-libxml-dir=/usr \
--with-ldap=shared --with-ldap-sasl \
- --enable-mbstring=shared --enable-mbregex \
+ --enable-mbstring=shared \
--with-mcrypt=shared \
--with-sqlite3=shared,/usr --with-pdo-sqlite=shared,/usr \
--with-pdo-dblib=shared \
--with-mysqli=shared,mysqlnd \
--enable-mysqlnd=shared --with-pdo-mysql=shared,mysqlnd --with-mysql-sock=/run/mysqld/mysqld.sock \
--with-pgsql=shared --with-pdo-pgsql=shared \
- --with-unixODBC=shared,/usr -with-pdo-odbc=shared,unixODBC,/usr \
+ --with-unixODBC=shared,/usr --with-pdo-odbc=shared,unixODBC,/usr \
--with-dbmaker=shared \
--enable-opcache=shared \
--enable-pdo=shared \
@@ -155,7 +158,7 @@ _build() {
--enable-xmlwriter=shared \
--with-xsl=shared \
--enable-wddx=shared \
- --enable-zip=shared --with-libzip=shared \
+ --enable-zip=shared --with-libzip=/usr \
$@ || return 1
make || return 1
}