aboutsummaryrefslogtreecommitdiffstats
path: root/community/picom
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-19 09:12:53 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-19 15:52:58 +0100
commit180c42b0d36742c55da41e08276a5618e2e44de0 (patch)
treec304cd28e2514b8708027bebb91d9040f7a4da7b /community/picom
parent7030e3a1d68a26fe21c3e50ed167e312be5d49e1 (diff)
downloadaports-180c42b0d36742c55da41e08276a5618e2e44de0.tar.bz2
aports-180c42b0d36742c55da41e08276a5618e2e44de0.tar.xz
community/picom: rename from compton
Diffstat (limited to 'community/picom')
-rw-r--r--community/picom/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/picom/APKBUILD b/community/picom/APKBUILD
new file mode 100644
index 0000000000..ecaaaea7a0
--- /dev/null
+++ b/community/picom/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=compton
+pkgver=7.4
+pkgrel=0
+pkgdesc="X Compositor (a fork of xcompmgr-dana)"
+url="https://github.com/yshui/compton"
+arch="all"
+license="MIT MPL-2.0"
+makedepends="libx11-dev libxcomposite-dev libxinerama-dev libxdamage-dev \
+ libconfig-dev pcre-dev libxrandr-dev dbus-dev libdrm-dev mesa-dev meson \
+ libev-dev libxdg-basedir-dev pixman-dev xcb-util-renderutil-dev \
+ xcb-util-image-dev asciidoc uthash-dev"
+subpackages="$pkgname-doc"
+source="compton-$pkgver.tar.gz::https://github.com/yshui/compton/archive/v$pkgver.tar.gz"
+options="!check" # No tests defined in tests/ directory
+
+build() {
+ meson --prefix=/usr --buildtype=release -Dwith_docs=true build
+ ninja -v -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+
+ mkdir -p "$pkgdir/usr/share/doc/compton"
+ install -m644 README* "$pkgdir/usr/share/doc/compton/"
+ install -D -m644 "compton.sample.conf" "$pkgdir/etc/xdg/compton.conf.example"
+}
+
+sha512sums="03dbe0a54cfea2594133daca76e2f0f908383ee74cdcc8e94d17d5cd0943abf86c58452876b422da081f3c3226545ad3553561d37c138e903c0fe76865c2f43a compton-7.4.tar.gz"